Skip to content

← Actionable
High, CVSS 7.5

Moodle vulnerable to brute-force password guesses

CVE-2025-62399GHSA-m58f-9pvv-8mp2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 5.0.3, 4.5.7, 4.4.11, 4.1.21), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist moodle/moodle

    Affected
    >= 5.0.0-beta, < 5.0.3>= 4.5.0-beta, < 4.5.7>= 4.2.0-beta, < 4.4.11< 4.1.21
    Fixed in
    4.1.21, 4.4.11, 5.0.3, 4.5.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2025-62399: 0.40% estimated exploitation activity in the next 30 days; percentile 34.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Moodle's mobile and web service authentication endpoints did not sufficiently restrict repeated password attempts, making them susceptible to brute-force attacks.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-m58f-9pvv-8mp2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-62399

Advisory: Moodle vulnerable to brute-force password guesses
IDs: CVE-2025-62399, GHSA-m58f-9pvv-8mp2
Record: https://patchnext.com/advisories/cve-2025-62399 (revision 1, source checked 26 Oct 2026, 14:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 5.0.3, 4.5.7, 4.4.11, 4.1.21. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist moodle/moodle: affected >= 5.0.0-beta, < 5.0.3; >= 4.5.0-beta, < 4.5.7; >= 4.2.0-beta, < 4.4.11; < 4.1.21; fixed in 4.1.21, 4.4.11, 5.0.3, 4.5.7

## Suggested inspection (read-only)
- Packagist moodle/moodle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on moodle/moodle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m58f-9pvv-8mp2 (GitHub-reviewed advisory GHSA-m58f-9pvv-8mp2 lists affected ranges: Packagist moodle/moodle >=5.0.0-beta =4.5.0-beta =4.2.0-beta =0 <4.1.21)

Commands are suggestions: review each one before running it.

Loading voting…