Skip to content

← Actionable
High, CVSS 8.3amended

sveltekit-superforms has Prototype Pollution in parseFormData function of formData.js

CVE-2025-62381GHSA-hwmc-4c8j-xxj7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sveltekit-superforms 2.27.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.3 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:L/VA:H/SC:L/SI:L/SA:L · score source
EPSS
  • CVE-2025-62381: 0.73% estimated exploitation activity in the next 30 days; percentile 54.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary sveltekit-superforms v2.27.3 and prior are susceptible to a prototype pollution vulnerability within the parseFormData function of formData.js. An attacker can inject string and array properties into Object.prototype, leading to denial of service, type confusion, and potential remote code execution in downstream applications that rely on polluted objects. Details Superforms is a SvelteKit form library for server and client form validation. Under normal operation, form validation is performed by calling the the superValidate function, with the submitted form data and a form schema as arguments: Within the superValidate function, a call is made to parseRequest in order to parse the user's input. parseRequest then calls into parseFormData, which in turn looks for the presence of superformjson in the form parameters. If superformjson is present, the following snippet is executed: This snippet deserializes JSON input within the superformjson, and then performs a nested assignment…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-hwmc-4c8j-xxj7

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-hwmc-4c8j-xxj7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-62381

Advisory: `sveltekit-superforms` has Prototype Pollution in `parseFormData` function of `formData.js`
IDs: CVE-2025-62381, GHSA-hwmc-4c8j-xxj7
Record: https://patchnext.com/advisories/cve-2025-62381 (revision 3, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sveltekit-superforms 2.27.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm sveltekit-superforms: affected <= 2.27.3; fixed in 2.27.4

## Suggested inspection (read-only)
- `npm ls sveltekit-superforms --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sveltekit-superforms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hwmc-4c8j-xxj7 (OSV record GHSA-hwmc-4c8j-xxj7 lists affected ranges: npm sveltekit-superforms >=0 <2.27.4 (fixed))
- Verified: https://github.com/advisories/GHSA-hwmc-4c8j-xxj7 (GitHub-reviewed advisory GHSA-hwmc-4c8j-xxj7 lists affected ranges: npm sveltekit-superforms >=0 <=2.27.3)

Commands are suggestions: review each one before running it.

Loading voting…