Skip to content

← Actionable
Medium, CVSS 6.1amended

CommandKit has incorrect command name exposure in context object for message command aliases

CVE-2025-62378GHSA-fhwm-pc6r-4h2f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (commandkit 1.2.0-rc.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm commandkit

    Affected
    >= 1.2.0-rc.1, <= 1.2.0-rc.11
    Fixed in
    1.2.0-rc.12

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N
EPSS
  • CVE-2025-62378: 0.16% estimated exploitation activity in the next 30 days; percentile 5.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A logic flaw exists in the message command handler of CommandKit that affects how the commandName property is exposed to both middleware functions and command execution contexts when handling command aliases. When a message command is invoked using an alias, the ctx.commandName value reflects the alias rather than the canonical command name. This occurs in both middleware functions and within the command’s own run function. Although not explicitly documented, CommandKit’s examples and guidance around middleware usage implicitly convey that ctx.commandName represents the canonical command identifier. Middleware examples in the documentation consistently use ctx.commandName to reference the command being executed, and the documentation describes middleware as suitable for “logging, authentication, permission checks, or any other cross-cutting concerns.” As a result, developers reasonably expect ctx.commandName to return the canonical command name and may rely on it for…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-fhwm-pc6r-4h2f

  2. Revision 1 · created ·

    Published from osv record GHSA-fhwm-pc6r-4h2f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-62378

Advisory: CommandKit has incorrect command name exposure in context object for message command aliases
IDs: CVE-2025-62378, GHSA-fhwm-pc6r-4h2f
Record: https://patchnext.com/advisories/cve-2025-62378 (revision 2, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: commandkit 1.2.0-rc.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm commandkit: affected >= 1.2.0-rc.1, <= 1.2.0-rc.11; fixed in 1.2.0-rc.12

## Suggested inspection (read-only)
- `npm ls commandkit --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on commandkit.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fhwm-pc6r-4h2f (OSV record GHSA-fhwm-pc6r-4h2f lists affected ranges: npm commandkit >=1.2.0-rc.1 <1.2.0-rc.12 (fixed))
- Verified: https://github.com/advisories/GHSA-fhwm-pc6r-4h2f (GitHub-reviewed advisory GHSA-fhwm-pc6r-4h2f lists affected ranges: npm commandkit >=1.2.0-rc.1 <=1.2.0-rc.11)

Commands are suggestions: review each one before running it.

Loading voting…