Skip to content

← Actionable
High, CVSS 7.4

OpenSearch Data Prepper plugins trust all SSL certificates by default

CVE-2025-62371GHSA-43ff-rr26-8hx4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.opensearch.dataprepper.plugins:opensearch 2.12.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2025-62371: 0.19% estimated exploitation activity in the next 30 days; percentile 9.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The OpenSearch sink and source plugins in Data Prepper are configured to trust all SSL certificates by default when no certificate path was provided, making connections vulnerable to man-in-the-middle attacks. Prior to this fix, the OpenSearch sink and source plugins would automatically use a trust all SSL strategy when connecting to OpenSearch clusters if no certificate path was explicitly configured. This behavior bypassed SSL certificate validation, potentially allowing attackers to intercept and modify data in transit through man-in-the-middle attacks. The vulnerability affects connections to OpenSearch when the cert parameter is not explicitly provided. Patches Data Prepper 2.12.2 Workarounds If you cannot immediately upgrade to the fixed version, you can implement the following workaround. OpenSearch sink Add the cert parameter to your OpenSearch sink configuration with the path to your cluster's CA certificate. The following example shows how to accomplish this.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-43ff-rr26-8hx4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-62371

Advisory: OpenSearch Data Prepper plugins trust all SSL certificates by default
IDs: CVE-2025-62371, GHSA-43ff-rr26-8hx4
Record: https://patchnext.com/advisories/cve-2025-62371 (revision 1, source checked 26 Oct 2026, 16:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.opensearch.dataprepper.plugins:opensearch 2.12.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.opensearch.dataprepper.plugins:opensearch: affected < 2.12.2; fixed in 2.12.2

## Suggested inspection (read-only)
- Maven org.opensearch.dataprepper.plugins:opensearch: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.opensearch.dataprepper.plugins:opensearch.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-43ff-rr26-8hx4 (GitHub-reviewed advisory GHSA-43ff-rr26-8hx4 lists affected ranges: Maven org.opensearch.dataprepper.plugins:opensearch >=0 <2.12.2)

Commands are suggestions: review each one before running it.

Loading voting…