Skip to content

← Actionable
High, CVSS 7.5

alloy-dyn-abi has DoS vulnerability on alloy_dyn_abi::TypedData hashing

CVE-2025-62370GHSA-pgp9-98jm-wwq2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (alloy-dyn-abi 1.4.1, 0.8.26), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io alloy-dyn-abi

    Affected
    < 0.8.26>= 1.0.0, < 1.4.1
    Fixed in
    1.4.1, 0.8.26

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2025-62370: 0.45% estimated exploitation activity in the next 30 days; percentile 38.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An uncaught panic triggered by malformed input to alloydynabi::TypedData could lead to a denial-of-service (DoS) via eip712signinghash(). Software with high availability requirements such as network services may be particularly impacted. If in use, external auto-restarting mechanisms can partially mitigate the availability issues unless repeated attacks are possible. Patches The vulnerability was patched by adding a check to ensure the element is not empty before accessing its first element; an error is returned if it is empty. The fix is included in version v1.4.1 and backported to v0.8.26. Workarounds There is no known workaround that mitigates the vulnerability. Upgrading to a patched version is the recommended course of action. Reported by Christian Reitter & Zeke Mostov from Turnkey

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-pgp9-98jm-wwq2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-62370

Advisory: alloy-dyn-abi has DoS vulnerability on `alloy_dyn_abi::TypedData` hashing
IDs: CVE-2025-62370, GHSA-pgp9-98jm-wwq2
Record: https://patchnext.com/advisories/cve-2025-62370 (revision 1, source checked 26 Oct 2026, 15:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: alloy-dyn-abi 1.4.1, 0.8.26. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io alloy-dyn-abi: affected < 0.8.26; >= 1.0.0, < 1.4.1; fixed in 1.4.1, 0.8.26

## Suggested inspection (read-only)
- crates.io alloy-dyn-abi: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on alloy-dyn-abi.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pgp9-98jm-wwq2 (GitHub-reviewed advisory GHSA-pgp9-98jm-wwq2 lists affected ranges: crates.io alloy-dyn-abi >=0 =1.0.0 <1.4.1)

Commands are suggestions: review each one before running it.

Loading voting…