Skip to content

← Actionable
Low, CVSS 1.3amended

Mailgen has HTML Injection and XSS Filter Bypass in Plaintext Emails

CVE-2025-62366GHSA-xw6r-chmh-vpmj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mailgen 2.0.31), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm mailgen

    Affected
    <= 2.0.30
    Fixed in
    2.0.31

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
1.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P · score source
EPSS
  • CVE-2025-62366: 0.43% estimated exploitation activity in the next 30 days; percentile 37.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An HTML injection vulnerability in plaintext emails generated by Mailgen has been discovered. Your project is affected if you use the Mailgen.generatePlaintext(email) method and pass in user-generated content. The issue was discovered and reported by Edoardo Ottavianelli (@edoardottt). Details The following function (inside index.js) is intended to strip all HTML content to produce a plaintext string. The process fails because it searches for HTML tags and attempts to strip them from the input. However, if the HTML tags are encoded, they are not removed. These encoded tags are then decoded later and become valid HTML content, which can lead to XSS vulnerabilities. A valid payload is: &ltimg src=xyz onerror=alert(1)&gt. PoC Resulting output file (emailText.html): Impact Depending on the context/environment where the plaintext message is used, if HTML is rendered and executed can result in arbitrary code execution in the browser of the victim (potentially stealing secrets or…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-xw6r-chmh-vpmj

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-xw6r-chmh-vpmj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-62366

Advisory: Mailgen has HTML Injection and XSS Filter Bypass in Plaintext Emails
IDs: CVE-2025-62366, GHSA-xw6r-chmh-vpmj
Record: https://patchnext.com/advisories/cve-2025-62366 (revision 3, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 1.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mailgen 2.0.31. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm mailgen: affected <= 2.0.30; fixed in 2.0.31

## Suggested inspection (read-only)
- `npm ls mailgen --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mailgen.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xw6r-chmh-vpmj (OSV record GHSA-xw6r-chmh-vpmj lists affected ranges: npm mailgen >=0 <2.0.31 (fixed))
- Verified: https://github.com/advisories/GHSA-xw6r-chmh-vpmj (GitHub-reviewed advisory GHSA-xw6r-chmh-vpmj lists affected ranges: npm mailgen >=0 <=2.0.30)

Commands are suggestions: review each one before running it.

Loading voting…