Skip to content

← Actionable
Medium, CVSS 5.5

LibreNMS is vulnerable to Reflected-XSS in report_this function

CVE-2025-62365GHSA-86rg-8hc8-v82p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (librenms/librenms 25.7.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P · score source
EPSS
  • CVE-2025-62365: 0.25% estimated exploitation activity in the next 30 days; percentile 16.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Reflected-XSS in reportthis function in librenms/includes/functions.php Details Recently, it was discovered that the reportthis function had improper filtering (htmlentities function was incorrectly used in a href environment), which caused the projectissues parameter to trigger an XSS vulnerability. The Vulnerable Sink: https://github.com/librenms/librenms/blob/master/includes/functions.php#L444 PoC GET projectissues=javascript:alert(document.cookie) Impact XSS vulnerabilities allow attackers to execute malicious scripts in users' browsers, enabling unauthorized access to sensitive data, session hijacking, or malware distribution. Suggestion It is recommended to filter dangerous protocols, e.g. javascript:/file:.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-86rg-8hc8-v82p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-62365

Advisory: LibreNMS is vulnerable to Reflected-XSS in `report_this` function
IDs: CVE-2025-62365, GHSA-86rg-8hc8-v82p
Record: https://patchnext.com/advisories/cve-2025-62365 (revision 1, source checked 26 Oct 2026, 14:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: librenms/librenms 25.7.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist librenms/librenms: affected <= 25.6.0; fixed in 25.7.0

## Suggested inspection (read-only)
- Packagist librenms/librenms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on librenms/librenms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-86rg-8hc8-v82p (GitHub-reviewed advisory GHSA-86rg-8hc8-v82p lists affected ranges: Packagist librenms/librenms >=0 <=25.6.0)

Commands are suggestions: review each one before running it.

Loading voting…