Skip to content

← Actionable
Low, CVSS 2.2

Mattermost has Insufficiently Protected Credentials

CVE-2025-6227GHSA-4fwj-8595-wp25

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost/server/v8 8.0.0-20250612074655-8f8612c63783; github.com/mattermost/mattermost-server 10.5.8, 9.11.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-4fwj-8595-wp25 lists affected ranges: Go github.com/mattermost/mattermost-server >=10.5.0 =9.11.0 =0 <8.0.0-20250612074655-8f8612c63783

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
2.2 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2025-6227: 0.22% estimated exploitation activity in the next 30 days; percentile 12.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Mattermost versions 10.5.x <= 10.5.7, 9.11.x <= 9.11.16 fail to negotiate a new token when accepting the invite which allows a user that intercepts both invite and password to send synchronization payloads to the server that originally created the invite via the REST API.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4fwj-8595-wp25

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-6227

Advisory: Mattermost has Insufficiently Protected Credentials
IDs: CVE-2025-6227, GHSA-4fwj-8595-wp25
Record: https://patchnext.com/advisories/cve-2025-6227 (revision 1, source checked 26 Oct 2026, 15:09 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost/server/v8 8.0.0-20250612074655-8f8612c63783; github.com/mattermost/mattermost-server 10.5.8, 9.11.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/mattermost/mattermost/server/v8: affected < 8.0.0-20250612074655-8f8612c63783; fixed in 8.0.0-20250612074655-8f8612c63783
- Go github.com/mattermost/mattermost-server: affected >= 10.5.0, < 10.5.8; >= 9.11.0, < 9.11.17; fixed in 9.11.17, 10.5.8

## Suggested inspection (read-only)
- Go github.com/mattermost/mattermost/server/v8: check the installed version with your package manager.
- Go github.com/mattermost/mattermost-server: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4fwj-8595-wp25 (GitHub-reviewed advisory GHSA-4fwj-8595-wp25 lists affected ranges: Go github.com/mattermost/mattermost-server >=10.5.0 =9.11.0 =0 <8.0.0-20250612074655-8f8612c63783)

Commands are suggestions: review each one before running it.

Loading voting…