Liferay Portal Commerce is vulnerable to XSS through account "name" field
CVE-2025-62237GHSA-m4g9-5mg6-gfr3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.liferay.commerce:com.liferay.commerce.order.web 5.0.101), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.liferay.commerce:com.liferay.commerce.order.web
- Affected
- >= 5.0.29, < 5.0.101
- Fixed in
- 5.0.101
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m4g9-5mg6-gfr3 lists affected ranges: Maven com.liferay.commerce:com.liferay.commerce.order.web >=5.0.29 <5.0.101
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 4.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-62237: 0.22% estimated exploitation activity in the next 30 days; percentile 13.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Stored cross-site scripting (XSS) vulnerability in Commerce’s view order page in Liferay Portal 7.4.3.8 through 7.4.3.111, and Liferay DXP 2023.Q4.0 through 2023.Q4.5, 2023.Q3.1 through 2023.Q3.8, and 7.4 update 8 through update 92 allows remote attackers to inject arbitrary web script or HTML via a crafted payload injected into an Account’s “Name” text field.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m4g9-5mg6-gfr3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-62237 Advisory: Liferay Portal Commerce is vulnerable to XSS through account "name" field IDs: CVE-2025-62237, GHSA-m4g9-5mg6-gfr3 Record: https://patchnext.com/advisories/cve-2025-62237 (revision 1, source checked 26 Oct 2026, 16:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.liferay.commerce:com.liferay.commerce.order.web 5.0.101. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.liferay.commerce:com.liferay.commerce.order.web: affected >= 5.0.29, < 5.0.101; fixed in 5.0.101 ## Suggested inspection (read-only) - Maven com.liferay.commerce:com.liferay.commerce.order.web: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.liferay.commerce:com.liferay.commerce.order.web. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m4g9-5mg6-gfr3 (GitHub-reviewed advisory GHSA-m4g9-5mg6-gfr3 lists affected ranges: Maven com.liferay.commerce:com.liferay.commerce.order.web >=5.0.29 <5.0.101) Commands are suggestions: review each one before running it.
Loading voting…