Home Assistant has Stored XSS vulnerability in Energy dashboard from Energy Entity Name
CVE-2025-62172GHSA-mq77-rv97-285m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (homeassistant 2025.10.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI homeassistant
- Affected
- >= 2025.1.0, <= 2025.10.1
- Fixed in
- 2025.10.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mq77-rv97-285m lists affected ranges: PyPI homeassistant >=2025.1.0 <2025.10.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mq77-rv97-285m lists affected ranges: PyPI homeassistant >=2025.1.0 <=2025.10.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:P · score source
- EPSS
- CVE-2025-62172: 0.43% estimated exploitation activity in the next 30 days; percentile 37.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An authenticated party can add a malicious name to the Energy entity, allowing for Cross-Site Scripting attacks against anyone who can see the Energy dashboard, when they hover over any information point (The blue bar in the picture below) <img width="955" height="568" alt="1cens" src="https://github.com/user-attachments/assets/ed855216-c306-4b50-affc-cda100e72b74" / An alternative, and more impactful scenario, is that the entity gets a malicious name from the provider of the Entity (in this case the energy provider: Tibber), and gets exploited that way, through the default name. Details The incriminating entity in my scenario is from the Tibber integration, as shown in the screenshot below: <img width="822" height="309" alt="2cens" src="https://github.com/user-attachments/assets/d0d5a7aa-8d0c-4dcb-825b-e4cb8ea8885b" / The exploit should be possible regardless of the Energy integration, as the user can name the entity themselves and as such pick a malicious name. The default…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-mq77-rv97-285m
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-mq77-rv97-285m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-62172 Advisory: Home Assistant has Stored XSS vulnerability in Energy dashboard from Energy Entity Name IDs: CVE-2025-62172, GHSA-mq77-rv97-285m Record: https://patchnext.com/advisories/cve-2025-62172 (revision 3, source checked 26 Oct 2026, 13:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: homeassistant 2025.10.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI homeassistant: affected >= 2025.1.0, <= 2025.10.1; fixed in 2025.10.2 ## Suggested inspection (read-only) - `python -m pip show homeassistant`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on homeassistant. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mq77-rv97-285m (OSV record GHSA-mq77-rv97-285m lists affected ranges: PyPI homeassistant >=2025.1.0 <2025.10.2 (fixed)) - Verified: https://github.com/advisories/GHSA-mq77-rv97-285m (GitHub-reviewed advisory GHSA-mq77-rv97-285m lists affected ranges: PyPI homeassistant >=2025.1.0 <=2025.10.1) Commands are suggestions: review each one before running it.
Loading voting…