Skip to content

← Actionable
Medium, CVSS 4.4

ImageMagick has Integer Overflow in BMP Decoder (ReadBMP)

CVE-2025-62171GHSA-9pp9-cfwx-54rm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (magick.net-q8-x86 14.9.0; magick.net-q16-hdri-anycpu 14.9.0; magick.net-q16-anycpu 14.9.0; magick.net-q16-hdri-x86 14.9.0; magick.net-q16-x86 14.9.0; 1 more package under Affected packages), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.4 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2025-62171: 0.81% estimated exploitation activity in the next 30 days; percentile 56.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary CVE-2025-57803 claims to be patched in ImageMagick 7.1.2-2, but the fix is incomplete and ineffective. The latest version 7.1.2-5 remains vulnerable to the same integer overflow attack. The patch added BMPOverflowCheck() but placed it after the overflow occurs, making it useless. A malicious 58-byte BMP file can trigger AddressSanitizer crashes and DoS. Affected Versions: - ImageMagick < 7.1.2-2 (originally reported) - ImageMagick 7.1.2-2 through 7.1.2-5 (incomplete patch) Platform and Configuration Requirements: - 32-bit systems ONLY (i386, i686, armv7l, etc.) - Requires sizet = 4 bytes. (64-bit systems are NOT vulnerable (sizet = 8 bytes)) - Requires modified resource limits: The default width, height, and area limits must have been manually increased (Systems using default ImageMagick resource limits are NOT vulnerable). --- Details(Root Cause Analysis) Vulnerable Code Location File: coders/bmp.c Lines: 1120-1122 (in version 7.1.2-5) The Incomplete Patch Why the Patch…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9pp9-cfwx-54rm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-62171

Advisory: ImageMagick has Integer Overflow in BMP Decoder (ReadBMP)
IDs: CVE-2025-62171, GHSA-9pp9-cfwx-54rm
Record: https://patchnext.com/advisories/cve-2025-62171 (revision 1, source checked 26 Oct 2026, 17:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: magick.net-q8-x86 14.9.0; magick.net-q16-hdri-anycpu 14.9.0; magick.net-q16-anycpu 14.9.0; magick.net-q16-hdri-x86 14.9.0; magick.net-q16-x86 14.9.0; magick.net-q8-anycpu 14.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet magick.net-q8-x86: affected < 14.9.0; fixed in 14.9.0
- NuGet magick.net-q16-hdri-anycpu: affected < 14.9.0; fixed in 14.9.0
- NuGet magick.net-q16-anycpu: affected < 14.9.0; fixed in 14.9.0
- NuGet magick.net-q16-hdri-x86: affected < 14.9.0; fixed in 14.9.0
- NuGet magick.net-q16-x86: affected < 14.9.0; fixed in 14.9.0
- NuGet magick.net-q8-anycpu: affected < 14.9.0; fixed in 14.9.0

## Suggested inspection (read-only)
- NuGet magick.net-q8-x86: check the installed version with your package manager.
- NuGet magick.net-q16-hdri-anycpu: check the installed version with your package manager.
- NuGet magick.net-q16-anycpu: check the installed version with your package manager.
- NuGet magick.net-q16-hdri-x86: check the installed version with your package manager.
- NuGet magick.net-q16-x86: check the installed version with your package manager.
- NuGet magick.net-q8-anycpu: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on magick.net-q8-x86, magick.net-q16-hdri-anycpu, magick.net-q16-anycpu, magick.net-q16-hdri-x86, magick.net-q16-x86, magick.net-q8-anycpu.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9pp9-cfwx-54rm (GitHub-reviewed advisory GHSA-9pp9-cfwx-54rm lists affected ranges: NuGet magick.net-q16-anycpu >=0 =0 =0 =0 =0 =0 <14.9.0)

Commands are suggestions: review each one before running it.

Loading voting…