Skip to content

← Actionable
High, CVSS 8.8amended

vLLM deserialization vulnerability leading to DoS and potential RCE

CVE-2025-62164GHSA-mrw7-hf4f-83pf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.11.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI vllm

    Affected
    >= 0.10.2, < 0.11.1
    Fixed in
    0.11.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2025-62164: 0.96% estimated exploitation activity in the next 30 days; percentile 61.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A memory corruption vulnerability that leading to a crash (denial-of-service) and potentially remote code execution (RCE) exists in vLLM versions 0.10.2 and later, in the Completions API endpoint. When processing user-supplied prompt embeddings, the endpoint loads serialized tensors using torch.load() without sufficient validation. Due to a change introduced in PyTorch 2.8.0, sparse tensor integrity checks are disabled by default. As a result, maliciously crafted tensors can bypass internal bounds checks and trigger an out-of-bounds memory write during the call to todense(). This memory corruption can crash vLLM and potentially lead to code execution on the server hosting vLLM. Details A vulnerability that can lead to RCE from the completions API endpoint exists in vllm, where due to missing checks when loading user-provided tensors, an out-of-bounds write can be triggered. This happens because the default behavior of torch.load(tensor, weightsonly=True) since pytorch 2.8.0…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mrw7-hf4f-83pf

  2. Revision 1 · created ·

    Published from osv record GHSA-mrw7-hf4f-83pf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-62164

Advisory: vLLM deserialization vulnerability leading to DoS and potential RCE
IDs: CVE-2025-62164, GHSA-mrw7-hf4f-83pf
Record: https://patchnext.com/advisories/cve-2025-62164 (revision 2, source checked 26 Oct 2026, 13:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vllm 0.11.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vllm: affected >= 0.10.2, < 0.11.1; fixed in 0.11.1

## Suggested inspection (read-only)
- `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vllm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mrw7-hf4f-83pf (OSV record GHSA-mrw7-hf4f-83pf lists affected ranges: PyPI vllm >=0.10.2 <0.11.1 (fixed))
- Verified: https://github.com/advisories/GHSA-mrw7-hf4f-83pf (GitHub-reviewed advisory GHSA-mrw7-hf4f-83pf lists affected ranges: PyPI vllm >=0.10.2 <0.11.1)

Commands are suggestions: review each one before running it.

Loading voting…