youki container escape via "masked path" abuse due to mount race conditions
CVE-2025-62161GHSA-4g74-7cff-xcv8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (youki 0.5.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io youki
- Affected
- < 0.5.7
- Fixed in
- 0.5.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4g74-7cff-xcv8 lists affected ranges: crates.io youki >=0 <0.5.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.3 · CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2025-62161: 0.26% estimated exploitation activity in the next 30 days; percentile 17.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact
youki utilizes bind mounting the container's /dev/null as a file mask. When performing this operation, the initial validation of the source /dev/null was insufficient. Specifically, we initially failed to verify whether /dev/null was genuinely present. However, we did perform validation to ensure that the /dev/null path existed within the container, including checking for symbolic links. Additionally, there was a vulnerability in the timing between validation and the actual mount operation. As a result, by replacing /dev/null with a symbolic link, we can bind-mount arbitrary files from the host system. This is a different project, but the core logic is similar to the CVE in runc. Issues were identified in runc, and verification was also conducted in youki to confirm the problems. https://github.com/opencontainers/runc/security/advisories/GHSA-9493-h29p-rfm2 Credits Thanks to Lei Wang (@ssst0n3 from Huawei) for finding and reporting the original runc's vulnerability (Attack…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4g74-7cff-xcv8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-62161 Advisory: youki container escape via "masked path" abuse due to mount race conditions IDs: CVE-2025-62161, GHSA-4g74-7cff-xcv8 Record: https://patchnext.com/advisories/cve-2025-62161 (revision 1, source checked 26 Oct 2026, 15:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: youki 0.5.7. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io youki: affected < 0.5.7; fixed in 0.5.7 ## Suggested inspection (read-only) - crates.io youki: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on youki. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4g74-7cff-xcv8 (GitHub-reviewed advisory GHSA-4g74-7cff-xcv8 lists affected ranges: crates.io youki >=0 <0.5.7) Commands are suggestions: review each one before running it.
Loading voting…