new-api is vulnerable to SSRF Bypass
CVE-2025-62155GHSA-9f46-w24h-69w4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/QuantumNous/new-api 0.9.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/QuantumNous/new-api
- Affected
- < 0.9.6
- Fixed in
- 0.9.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9f46-w24h-69w4 lists affected ranges: Go github.com/QuantumNous/new-api >=0 <0.9.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
- EPSS
- CVE-2025-62155: 0.30% estimated exploitation activity in the next 30 days; percentile 22.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A recently patched SSRF vulnerability contains a bypass method that can bypass the existing security fix and still allow SSRF to occur. Because the existing fix only applies security restrictions to the first URL request, a 302 redirect can bypass existing security measures and successfully access the intranet. Details Use the following script to deploy on the attacker's server. Since ports 80, 443, and 8080 are default ports within the security range set by the administrator and will not be blocked, the service is deployed on port 8080. Then, a request is made to the malicious service opened by the attacker, and it can be found that the resources on the intranet are successfully accessed. <img width="663" height="60" alt="image" src="https://github.com/user-attachments/assets/2f296cff-510d-4cfe-8509-518e747bf8fe" / At the same time, the locally opened service 127.0.0.1:8083/uid.txt also received related requests. <img width="717" height="79" alt="image"…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9f46-w24h-69w4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-62155 Advisory: new-api is vulnerable to SSRF Bypass IDs: CVE-2025-62155, GHSA-9f46-w24h-69w4 Record: https://patchnext.com/advisories/cve-2025-62155 (revision 1, source checked 26 Oct 2026, 15:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/QuantumNous/new-api 0.9.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/QuantumNous/new-api: affected < 0.9.6; fixed in 0.9.6 ## Suggested inspection (read-only) - Go github.com/QuantumNous/new-api: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/QuantumNous/new-api. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9f46-w24h-69w4 (GitHub-reviewed advisory GHSA-9f46-w24h-69w4 lists affected ranges: Go github.com/QuantumNous/new-api >=0 <0.9.6) Commands are suggestions: review each one before running it.
Loading voting…