LlamaIndex vulnerable to data loss through hash collisions in its DocugamiReader class
CVE-2025-6211GHSA-5hq9-5r78-2gjh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (llama-index 0.12.41; llama-index-readers-docugami 0.3.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI llama-index
- Affected
- < 0.12.41
- Fixed in
- 0.12.41
PyPI llama-index-readers-docugami
- Affected
- < 0.3.1
- Fixed in
- 0.3.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5hq9-5r78-2gjh lists affected ranges: PyPI llama-index >=0 =0 <0.3.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5hq9-5r78-2gjh lists affected ranges: PyPI llama-index >=0 =0 <0.3.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
- EPSS
- CVE-2025-6211: 0.36% estimated exploitation activity in the next 30 days; percentile 29.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability in the DocugamiReader class of the run-llama/llamaindex repository, up to but excluding version 0.12.41, involves the use of MD5 hashing to generate IDs for document chunks. This approach leads to hash collisions when structurally distinct chunks contain identical text, resulting in one chunk overwriting another. This can cause loss of semantically or legally important document content, breakage of parent-child chunk hierarchies, and inaccurate or hallucinated responses in AI outputs. The issue is resolved in version 0.3.1.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-5hq9-5r78-2gjh
- Revision 1 · created ·
Published from osv record GHSA-5hq9-5r78-2gjh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-6211 Advisory: LlamaIndex vulnerable to data loss through hash collisions in its DocugamiReader class IDs: CVE-2025-6211, GHSA-5hq9-5r78-2gjh Record: https://patchnext.com/advisories/cve-2025-6211 (revision 2, source checked 26 Oct 2026, 13:32 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: llama-index 0.12.41; llama-index-readers-docugami 0.3.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI llama-index: affected < 0.12.41; fixed in 0.12.41 - PyPI llama-index-readers-docugami: affected < 0.3.1; fixed in 0.3.1 ## Suggested inspection (read-only) - `python -m pip show llama-index`: prints the installed version. Run with the environment that serves production active. - `python -m pip show llama-index-readers-docugami`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on llama-index, llama-index-readers-docugami. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5hq9-5r78-2gjh (OSV record GHSA-5hq9-5r78-2gjh lists affected ranges: PyPI llama-index >=0 =0 <0.3.1 (fixed)) - Verified: https://github.com/advisories/GHSA-5hq9-5r78-2gjh (GitHub-reviewed advisory GHSA-5hq9-5r78-2gjh lists affected ranges: PyPI llama-index >=0 =0 <0.3.1) Commands are suggestions: review each one before running it.
Loading voting…