Skip to content

← Actionable
High, CVSS 7.5amended

LlamaIndex vulnerable to Path Traversal attack through its encode_image function

CVE-2025-6209GHSA-2rhq-96q8-4vjq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (llama-index 0.12.41; llama-index-core 0.12.41), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2025-6209: 0.62% estimated exploitation activity in the next 30 days; percentile 49.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A path traversal vulnerability exists in run-llama/llamaindex versions 0.11.23 through 0.12.40, specifically within the encodeimage function in genericutils.py. This vulnerability allows an attacker to manipulate the imagepath input to read arbitrary files on the server, including sensitive system files. The issue arises due to improper validation or sanitization of the file path, enabling path traversal sequences to access files outside the intended directory. The vulnerability is fixed in version 0.12.41.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-2rhq-96q8-4vjq

  2. Revision 2 · amended ·

    Amended from osv record PYSEC-2025-65

  3. Revision 1 · created ·

    Published from osv record GHSA-2rhq-96q8-4vjq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-6209

Advisory: LlamaIndex vulnerable to Path Traversal attack through its encode_image function
IDs: CVE-2025-6209, GHSA-2rhq-96q8-4vjq
Record: https://patchnext.com/advisories/cve-2025-6209 (revision 3, source checked 26 Oct 2026, 13:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: llama-index 0.12.41; llama-index-core 0.12.41. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI llama-index: affected >= 0.12.27, < 0.12.41; fixed in 0.12.41
- PyPI llama-index-core: affected >= 0.11.23, < 0.12.41; fixed in 0.12.41

## Suggested inspection (read-only)
- `python -m pip show llama-index`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show llama-index-core`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on llama-index, llama-index-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2rhq-96q8-4vjq (OSV record GHSA-2rhq-96q8-4vjq lists affected ranges: PyPI llama-index-core >=0.11.23 <0.12.41 (fixed))
- Verified: https://osv.dev/vulnerability/PYSEC-2025-65 (OSV record PYSEC-2025-65 lists affected ranges: PyPI llama-index >=0.12.27 <0.12.41 (fixed))
- Verified: https://github.com/advisories/GHSA-2rhq-96q8-4vjq (GitHub-reviewed advisory GHSA-2rhq-96q8-4vjq lists affected ranges: PyPI llama-index-core >=0.11.23 <0.12.41)

Commands are suggestions: review each one before running it.

Loading voting…