llama-index-core vulnerable to Uncontrolled Resource Consumption
CVE-2025-6208GHSA-488g-hw5f-x29p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (llama-index-core 0.12.41), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI llama-index-core
- Affected
- < 0.12.41
- Fixed in
- 0.12.41
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-488g-hw5f-x29p lists affected ranges: PyPI llama-index-core >=0 <0.12.41 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-488g-hw5f-x29p lists affected ranges: PyPI llama-index-core >=0 <0.12.41
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2025-6208: 0.41% estimated exploitation activity in the next 30 days; percentile 35.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The SimpleDirectoryReader component in llamaindex.core version 0.12.23 suffers from uncontrolled memory consumption due to a resource management flaw. The vulnerability arises because the user-specified file limit (numfileslimit) is applied after all files in a directory are loaded into memory. This can lead to memory exhaustion and degraded performance, particularly in environments with limited resources. The issue is resolved in version 0.12.41.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-488g-hw5f-x29p
- Revision 1 · created ·
Published from osv record GHSA-488g-hw5f-x29p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-6208 Advisory: llama-index-core vulnerable to Uncontrolled Resource Consumption IDs: CVE-2025-6208, GHSA-488g-hw5f-x29p Record: https://patchnext.com/advisories/cve-2025-6208 (revision 2, source checked 26 Oct 2026, 13:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: llama-index-core 0.12.41. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI llama-index-core: affected < 0.12.41; fixed in 0.12.41 ## Suggested inspection (read-only) - `python -m pip show llama-index-core`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on llama-index-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-488g-hw5f-x29p (OSV record GHSA-488g-hw5f-x29p lists affected ranges: PyPI llama-index-core >=0 <0.12.41 (fixed)) - Verified: https://github.com/advisories/GHSA-488g-hw5f-x29p (GitHub-reviewed advisory GHSA-488g-hw5f-x29p lists affected ranges: PyPI llama-index-core >=0 <0.12.41) Commands are suggestions: review each one before running it.
Loading voting…