Better Auth: Unauthenticated API key creation through api-key plugin
CVE-2025-61928GHSA-99h5-pjcv-gr6v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (better-auth 1.3.26), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm better-auth
- Affected
- < 1.3.26
- Fixed in
- 1.3.26
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-99h5-pjcv-gr6v lists affected ranges: npm better-auth >=0 <1.3.26 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-99h5-pjcv-gr6v lists affected ranges: npm better-auth >=0 <1.3.26
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L
- EPSS
- CVE-2025-61928: 19.72% estimated exploitation activity in the next 30 days; percentile 97.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A critical authentication bypass was identified in the API key creation and update endpoints. An attacker could create or modify API keys for arbitrary users by supplying a victim’s user ID in the request body. Due to a flaw in how the authenticated user was derived, the endpoints could treat attacker-controlled input as an authenticated user object under certain conditions. Details The vulnerability originated from fallback logic used when determining the current user. When no session was present, the handler incorrectly allowed request-body data to populate the user context used for authorization decisions. Because server-side validation only executed when authentication was required, privileged fields were not properly protected. As a result, the API accepted unauthenticated requests that targeted other users. This same pattern affected both the API key creation and update routes. Impact Unauthenticated attackers could generate or modify API keys belonging to any user.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-99h5-pjcv-gr6v
- Revision 1 · created ·
Published from osv record GHSA-99h5-pjcv-gr6v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-61928 Advisory: Better Auth: Unauthenticated API key creation through api-key plugin IDs: CVE-2025-61928, GHSA-99h5-pjcv-gr6v Record: https://patchnext.com/advisories/cve-2025-61928 (revision 2, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: better-auth 1.3.26. A vendor fix does not mean a deployment is fixed. ## Affected components - npm better-auth: affected < 1.3.26; fixed in 1.3.26 ## Suggested inspection (read-only) - `npm ls better-auth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on better-auth. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-99h5-pjcv-gr6v (OSV record GHSA-99h5-pjcv-gr6v lists affected ranges: npm better-auth >=0 <1.3.26 (fixed)) - Verified: https://github.com/advisories/GHSA-99h5-pjcv-gr6v (GitHub-reviewed advisory GHSA-99h5-pjcv-gr6v lists affected ranges: npm better-auth >=0 <1.3.26) Commands are suggestions: review each one before running it.
Loading voting…