PrestaShop Checkout Backoffice directory traversal allows arbitrary file disclosure
CVE-2025-61923GHSA-fpxp-pfqm-x54w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (prestashop/ps_checkout 5.0.5, 4.4.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist prestashop/ps_checkout
- Affected
- < 4.4.1>= 5.0.0, < 5.0.5
- Fixed in
- 4.4.1, 5.0.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fpxp-pfqm-x54w lists affected ranges: Packagist prestashop/ps_checkout >=0 =5.0.0 <5.0.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.1 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:N/A:N
- EPSS
- CVE-2025-61923: 0.92% estimated exploitation activity in the next 30 days; percentile 60.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Missing validation on input vulnerable to directory traversal. Patches The problem has been patched in versions: v4.4.1 for PrestaShop 1.7 (build number: 7.4.4.1) v4.4.1 for PrestaShop 8 (build number: 8.4.4.1) v5.0.5 for PrestaShop 1.7 (build number: 7.5.0.5) v5.0.5 for PrestaShop 8 (build number: 8.5.0.5) v5.0.5 for PrestaShop 9 (build number: 9.5.0.5) Read the Versioning policy to learn more about the build number. Credits Léo CUNÉAZ for reportied this issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fpxp-pfqm-x54w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-61923 Advisory: PrestaShop Checkout Backoffice directory traversal allows arbitrary file disclosure IDs: CVE-2025-61923, GHSA-fpxp-pfqm-x54w Record: https://patchnext.com/advisories/cve-2025-61923 (revision 1, source checked 26 Oct 2026, 14:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: prestashop/ps_checkout 5.0.5, 4.4.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist prestashop/ps_checkout: affected < 4.4.1; >= 5.0.0, < 5.0.5; fixed in 4.4.1, 5.0.5 ## Suggested inspection (read-only) - Packagist prestashop/ps_checkout: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on prestashop/ps_checkout. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fpxp-pfqm-x54w (GitHub-reviewed advisory GHSA-fpxp-pfqm-x54w lists affected ranges: Packagist prestashop/ps_checkout >=0 =5.0.0 <5.0.5) Commands are suggestions: review each one before running it.
Loading voting…