Skip to content

← Actionable
High, CVSS 7.5amended

Authlib is vulnerable to Denial of Service via Oversized JOSE Segments

CVE-2025-61920GHSA-pq5p-34cr-23v9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (authlib 1.6.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI authlib

    Affected
    < 1.6.5
    Fixed in
    1.6.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2025-61920: 0.64% estimated exploitation activity in the next 30 days; percentile 50.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Authlib’s JOSE implementation accepts unbounded JWS/JWT header and signature segments. A remote attacker can craft a token whose base64url‑encoded header or signature spans hundreds of megabytes. During verification, Authlib decodes and parses the full input before it is rejected, driving CPU and memory consumption to hostile levels and enabling denial of service. Impact - Attack vector: unauthenticated network attacker submits a malicious JWS/JWT. - Effect: base64 decode + JSON/crypto processing of huge buffers pegs CPU and allocates large amounts of RAM; a single request can exhaust service capacity. - Observed behaviour: on a test host, the legacy code verified a 500 MB header, consuming ~4 GB RSS and ~9 s CPU before failing. - Severity: High. CVSS v3.1: AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H (7.5). Affected Versions Authlib ≤ 1.6.3 (and earlier) when verifying JWS/JWT tokens. Later snapshots with 256 KB header/signature limits are not affected. Proof of concept Local demo…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-pq5p-34cr-23v9

  2. Revision 1 · created ·

    Published from osv record GHSA-pq5p-34cr-23v9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-61920

Advisory: Authlib is vulnerable to Denial of Service via Oversized JOSE Segments
IDs: CVE-2025-61920, GHSA-pq5p-34cr-23v9
Record: https://patchnext.com/advisories/cve-2025-61920 (revision 2, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: authlib 1.6.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI authlib: affected < 1.6.5; fixed in 1.6.5

## Suggested inspection (read-only)
- `python -m pip show authlib`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on authlib.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-pq5p-34cr-23v9 (OSV record GHSA-pq5p-34cr-23v9 lists affected ranges: PyPI authlib >=0 <1.6.5 (fixed))
- Verified: https://github.com/advisories/GHSA-pq5p-34cr-23v9 (GitHub-reviewed advisory GHSA-pq5p-34cr-23v9 lists affected ranges: PyPI authlib >=0 <1.6.5)

Commands are suggestions: review each one before running it.

Loading voting…