Rack is vulnerable to a memory-exhaustion DoS through unbounded URL-encoded body parsing
CVE-2025-61919GHSA-6xw4-3v39-52mm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (rack 3.2.3, 3.1.18, 2.2.20), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems rack
- Affected
- < 2.2.20>= 3.0, < 3.1.18>= 3.2, < 3.2.3
- Fixed in
- 3.1.18, 3.2.3, 2.2.20
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6xw4-3v39-52mm lists affected ranges: RubyGems rack >=0 =3.0 =3.2 <3.2.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2025-61919: 0.65% estimated exploitation activity in the next 30 days; percentile 51.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Rack::Request#POST reads the entire request body into memory for Content-Type: application/x-www-form-urlencoded, calling rack.input.read(nil) without enforcing a length or cap. Large request bodies can therefore be buffered completely into process memory before parsing, leading to denial of service (DoS) through memory exhaustion. Details When handling non-multipart form submissions, Rack’s request parser performs: Since read is called with no argument, the entire request body is loaded into a Ruby String. This occurs before query parameter parsing or enforcement of any paramslimit. As a result, Rack applications without an upstream body-size limit can experience unbounded memory allocation proportional to request size. Impact Attackers can send large application/x-www-form-urlencoded bodies to consume process memory, causing slowdowns or termination by the operating system (OOM). The effect scales linearly with request size and concurrency. Even with parsing limits…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6xw4-3v39-52mm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-61919 Advisory: Rack is vulnerable to a memory-exhaustion DoS through unbounded URL-encoded body parsing IDs: CVE-2025-61919, GHSA-6xw4-3v39-52mm Record: https://patchnext.com/advisories/cve-2025-61919 (revision 1, source checked 26 Oct 2026, 15:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: rack 3.2.3, 3.1.18, 2.2.20. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems rack: affected < 2.2.20; >= 3.0, < 3.1.18; >= 3.2, < 3.2.3; fixed in 3.1.18, 3.2.3, 2.2.20 ## Suggested inspection (read-only) - RubyGems rack: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on rack. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6xw4-3v39-52mm (GitHub-reviewed advisory GHSA-6xw4-3v39-52mm lists affected ranges: RubyGems rack >=0 =3.0 =3.2 <3.2.3) Commands are suggestions: review each one before running it.
Loading voting…