Skip to content

← Actionable
High, CVSS 7.3amended

n8n's Possible Stored XSS in "Respond to Webhook" Node May Execute Outside iframe Sandbox

CVE-2025-61914GHSA-58jc-rcg5-95f3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 1.114.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm n8n

    Affected
    < 1.114.0
    Fixed in
    1.114.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
EPSS
  • CVE-2025-61914: 0.24% estimated exploitation activity in the next 30 days; percentile 15.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A stored Cross-Site Scripting (XSS) vulnerability may occur in n8n when using the “Respond to Webhook” node. When this node responds with HTML content containing executable scripts, the payload may execute directly in the top-level window, rather than within the expected sandbox introduced in version 1.103.0. This behavior can enable a malicious actor with workflow creation permissions to execute arbitrary JavaScript in the context of the n8n editor interface. While session cookies (n8n-auth) are marked HttpOnly and cannot be directly exfiltrated, the vulnerability can facilitate Cross-Site Request Forgery (CSRF)-like actions from within the user’s authenticated session, potentially allowing: - Unauthorized reading of sensitive workflow data or execution history. - Unauthorized modification or deletion of workflows. - Insertion of malicious workflow logic or external data exfiltration steps. n8n instances that allow untrusted users to create workflows are particularly…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-58jc-rcg5-95f3

  2. Revision 1 · created ·

    Published from osv record GHSA-58jc-rcg5-95f3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-61914

Advisory: n8n's Possible Stored XSS in "Respond to Webhook" Node May Execute Outside iframe Sandbox
IDs: CVE-2025-61914, GHSA-58jc-rcg5-95f3
Record: https://patchnext.com/advisories/cve-2025-61914 (revision 2, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: n8n 1.114.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm n8n: affected < 1.114.0; fixed in 1.114.0

## Suggested inspection (read-only)
- `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on n8n.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-58jc-rcg5-95f3 (OSV record GHSA-58jc-rcg5-95f3 lists affected ranges: npm n8n >=0 <1.114.0 (fixed))
- Verified: https://github.com/advisories/GHSA-58jc-rcg5-95f3 (GitHub-reviewed advisory GHSA-58jc-rcg5-95f3 lists affected ranges: npm n8n >=0 <1.114.0)

Commands are suggestions: review each one before running it.

Loading voting…