Skip to content

← Actionable
Medium, CVSS 5.5amended

python-ldap has sanitization bypass in ldap.filter.escape_filter_chars

CVE-2025-61911GHSA-r7r6-cc7p-4v5m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (python-ldap 3.4.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2025-61911: 0.32% estimated exploitation activity in the next 30 days; percentile 25.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The sanitization method ldap.filter.escapefilterchars can be tricked to skip escaping of special characters when a crafted list or dict is supplied as the assertionvalue parameter, and the non-default escapemode=1 is configured. Details The method ldap.filter.escapefilterchars supports 3 different escaping modes. escapemode=0 (default) and escapemode=2 happen to raise exceptions when a list or dict object is supplied as the assertionvalue parameter. However, escapemode=1 happily computes without performing adequate logic to ensure a fully escaped return value. PoC Exploitable Not exploitable Impact If an application relies on the vulnerable method in the python-ldap library to escape untrusted user input, an attacker might be able to abuse the vulnerability to launch ldap injection attacks which could potentially disclose or manipulate ldap data meant to be inaccessible to them. With Python being a dynamically typed language, and the commonly used JSON format supporting list…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-r7r6-cc7p-4v5m

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-r7r6-cc7p-4v5m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-61911

Advisory: python-ldap has sanitization bypass in ldap.filter.escape_filter_chars
IDs: CVE-2025-61911, GHSA-r7r6-cc7p-4v5m
Record: https://patchnext.com/advisories/cve-2025-61911 (revision 3, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: python-ldap 3.4.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI python-ldap: affected < 3.4.5; fixed in 3.4.5

## Suggested inspection (read-only)
- `python -m pip show python-ldap`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on python-ldap.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-r7r6-cc7p-4v5m (OSV record GHSA-r7r6-cc7p-4v5m lists affected ranges: PyPI python-ldap >=0 <3.4.5 (fixed))
- Verified: https://github.com/advisories/GHSA-r7r6-cc7p-4v5m (GitHub-reviewed advisory GHSA-r7r6-cc7p-4v5m lists affected ranges: PyPI python-ldap >=0 <3.4.5)

Commands are suggestions: review each one before running it.

Loading voting…