Skip to content

← Actionable
High, CVSS 7.6amended

LLaMA Factory's Chat API Contains Critical SSRF and LFI Vulnerabilities

CVE-2025-61784GHSA-527m-2xhr-j27g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (llamafactory 0.9.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:L
EPSS
  • CVE-2025-61784: 0.38% estimated exploitation activity in the next 30 days; percentile 32.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary

A Server-Side Request Forgery (SSRF) vulnerability in the chat API allows any authenticated user to force the server to make arbitrary HTTP requests to internal and external networks. This can lead to the exposure of sensitive internal services, reconnaissance of the internal network, or interaction with third-party services. The same mechanism also allows for a Local File Inclusion (LFI) vulnerability, enabling users to read arbitrary files from the server's filesystem. Details

The vulnerability exists in the processrequest function within src/llamafactory/api/chat.py. This function is responsible for processing incoming multimodal content, including images, videos, and audio provided via URLs. The function checks if the provided URL is a base64 data URI or a local file path (os.path.isfile). If neither is true, it falls back to treating the URL as a web URI and makes a direct HTTP GET request using requests.get(url, stream=True).raw without any validation or…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-527m-2xhr-j27g

  2. Revision 1 · created ·

    Published from osv record GHSA-527m-2xhr-j27g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-61784

Advisory: LLaMA Factory's Chat API Contains Critical SSRF and LFI Vulnerabilities
IDs: CVE-2025-61784, GHSA-527m-2xhr-j27g
Record: https://patchnext.com/advisories/cve-2025-61784 (revision 2, source checked 26 Oct 2026, 13:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: llamafactory 0.9.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI llamafactory: affected <= 0.9.3; fixed in 0.9.4

## Suggested inspection (read-only)
- `python -m pip show llamafactory`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on llamafactory.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-527m-2xhr-j27g (OSV record GHSA-527m-2xhr-j27g lists affected ranges: PyPI llamafactory >=0 <0.9.4 (fixed))
- Verified: https://github.com/advisories/GHSA-527m-2xhr-j27g (GitHub-reviewed advisory GHSA-527m-2xhr-j27g lists affected ranges: PyPI llamafactory >=0 <=0.9.3)

Commands are suggestions: review each one before running it.

Loading voting…