Python Social Auth - Django has unsafe account association
CVE-2025-61783GHSA-wv4w-6qv2-qqfg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (social-auth-app-django 5.6.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 5.6.0
- Fixed in
- 5.6.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wv4w-6qv2-qqfg lists affected ranges: PyPI social-auth-app-django >=0 <5.6.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wv4w-6qv2-qqfg lists affected ranges: PyPI social-auth-app-django >=0 <5.6.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-61783: 0.54% estimated exploitation activity in the next 30 days; percentile 45.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Upon authentication, the user could be associated by e-mail even if the associatebyemail pipeline was not included. This could lead to account compromise when a third-party authentication service does not validate provided e-mail addresses or doesn't require unique e-mail addresses. Patches https://github.com/python-social-auth/social-app-django/pull/803 Workarounds Review the authentication service policy on e-mail addresses; many will not allow exploiting this vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-wv4w-6qv2-qqfg
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-wv4w-6qv2-qqfg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-61783 Advisory: Python Social Auth - Django has unsafe account association IDs: CVE-2025-61783, GHSA-wv4w-6qv2-qqfg Record: https://patchnext.com/advisories/cve-2025-61783 (revision 3, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: social-auth-app-django 5.6.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI social-auth-app-django: affected < 5.6.0; fixed in 5.6.0 ## Suggested inspection (read-only) - `python -m pip show social-auth-app-django`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on social-auth-app-django. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-wv4w-6qv2-qqfg (OSV record GHSA-wv4w-6qv2-qqfg lists affected ranges: PyPI social-auth-app-django >=0 <5.6.0 (fixed)) - Verified: https://github.com/advisories/GHSA-wv4w-6qv2-qqfg (GitHub-reviewed advisory GHSA-wv4w-6qv2-qqfg lists affected ranges: PyPI social-auth-app-django >=0 <5.6.0) Commands are suggestions: review each one before running it.
Loading voting…