Rack has a Possible Information Disclosure Vulnerability
CVE-2025-61780GHSA-r657-rxjc-j557
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (rack 3.2.3, 3.1.18, 2.2.20), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems rack
- Affected
- < 2.2.20>= 3.0, < 3.1.18>= 3.2, < 3.2.3
- Fixed in
- 3.1.18, 3.2.3, 2.2.20
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r657-rxjc-j557 lists affected ranges: RubyGems rack >=0 =3.0 =3.2 <3.2.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N
- EPSS
- CVE-2025-61780: 0.55% estimated exploitation activity in the next 30 days; percentile 46.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A possible information disclosure vulnerability existed in Rack::Sendfile when running behind a proxy that supports x-sendfile headers (such as Nginx). Specially crafted headers could cause Rack::Sendfile to miscommunicate with the proxy and trigger unintended internal requests, potentially bypassing proxy-level access restrictions. Details When Rack::Sendfile received untrusted x-sendfile-type or x-accel-mapping headers from a client, it would interpret them as proxy configuration directives. This could cause the middleware to send a "redirect" response to the proxy, prompting it to reissue a new internal request that was not subject to the proxy's access controls. An attacker could exploit this by: 1. Setting a crafted x-sendfile-type: x-accel-redirect header. 2. Setting a crafted x-accel-mapping header. 3. Requesting a path that qualifies for proxy-based acceleration. Impact Attackers could bypass proxy-enforced restrictions and access internal endpoints intended to be…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-r657-rxjc-j557
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-61780 Advisory: Rack has a Possible Information Disclosure Vulnerability IDs: CVE-2025-61780, GHSA-r657-rxjc-j557 Record: https://patchnext.com/advisories/cve-2025-61780 (revision 1, source checked 26 Oct 2026, 15:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: rack 3.2.3, 3.1.18, 2.2.20. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems rack: affected < 2.2.20; >= 3.0, < 3.1.18; >= 3.2, < 3.2.3; fixed in 3.1.18, 3.2.3, 2.2.20 ## Suggested inspection (read-only) - RubyGems rack: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on rack. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-r657-rxjc-j557 (GitHub-reviewed advisory GHSA-r657-rxjc-j557 lists affected ranges: RubyGems rack >=0 =3.0 =3.2 <3.2.3) Commands are suggestions: review each one before running it.
Loading voting…