pyLoad CNL and captcha handlers allow Code Injection via unsanitized parameters
CVE-2025-61773GHSA-cjjf-27cc-pvmv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyload-ng 0.5.0b3.dev91), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pyload-ng
- Affected
- < 0.5.0b3.dev91
- Fixed in
- 0.5.0b3.dev91
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cjjf-27cc-pvmv lists affected ranges: PyPI pyload-ng >=0 <0.5.0b3.dev91 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cjjf-27cc-pvmv lists affected ranges: PyPI pyload-ng >=0 <0.5.0b3.dev91
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2025-61773: 0.52% estimated exploitation activity in the next 30 days; percentile 44.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary pyLoad web interface contained insufficient input validation in both the Captcha script endpoint and the Click'N'Load (CNL) Blueprint. This flaw allowed untrusted user input to be processed unsafely, which could be exploited by an attacker to inject arbitrary content into the web UI or manipulate request handling. The vulnerability could lead to client-side code execution (XSS) or other unintended behaviors when a malicious payload is submitted. user-supplied parameters from HTTP requests were not adequately validated or sanitized before being passed into the application logic and response generation. This allowed crafted input to alter the expected execution flow. CNL (Click'N'Load) blueprint exposed unsafe handling of untrusted parameters in HTTP requests. The application did not consistently enforce input validation or encoding, making it possible for an attacker to craft malicious requests. PoC 1. Run a vulnerable version of pyLoad prior to commit f9d27f2. 2. Start the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-cjjf-27cc-pvmv
- Revision 1 · created ·
Published from osv record GHSA-cjjf-27cc-pvmv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-61773 Advisory: pyLoad CNL and captcha handlers allow Code Injection via unsanitized parameters IDs: CVE-2025-61773, GHSA-cjjf-27cc-pvmv Record: https://patchnext.com/advisories/cve-2025-61773 (revision 2, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pyload-ng 0.5.0b3.dev91. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pyload-ng: affected < 0.5.0b3.dev91; fixed in 0.5.0b3.dev91 ## Suggested inspection (read-only) - `python -m pip show pyload-ng`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pyload-ng. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-cjjf-27cc-pvmv (OSV record GHSA-cjjf-27cc-pvmv lists affected ranges: PyPI pyload-ng >=0 <0.5.0b3.dev91 (fixed)) - Verified: https://github.com/advisories/GHSA-cjjf-27cc-pvmv (GitHub-reviewed advisory GHSA-cjjf-27cc-pvmv lists affected ranges: PyPI pyload-ng >=0 <0.5.0b3.dev91) Commands are suggestions: review each one before running it.
Loading voting…