Skip to content

← Actionable
High, CVSS 8.3amended

FlowiseAI/Flosise has File Upload vulnerability

CVE-2025-61687GHSA-35g6-rrw3-v6xc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flowise 3.0.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm flowise

    Affected
    >= 3.0.7, <= 3.0.7
    Fixed in
    3.0.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:H
EPSS
  • CVE-2025-61687: 11.76% estimated exploitation activity in the next 30 days; percentile 96.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A file upload vulnerability in FlowiseAI allows authenticated users to upload arbitrary files without proper validation. This enables attackers to persistently store malicious Node.js web shells on the server, potentially leading to Remote Code Execution (RCE). Details The system fails to validate file extensions, MIME types, or file content during uploads. As a result, malicious scripts such as Node.js-based web shells can be uploaded and stored persistently on the server. These shells expose HTTP endpoints capable of executing arbitrary commands if triggered. The uploaded shell does not automatically execute, but its presence allows future exploitation via administrator error or chained vulnerabilities. Taint Flow - Taint 01: Route Registration POST file requests are routed to the controller via Multer https://github.com/FlowiseAI/Flowise/blob/d29db16bfcf9a4be8febc3d19d52263e8c3d0055/packages/server/src/routes/attachments/index.ts#L8 - Taint 02: Multer Settings Uploaded…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-35g6-rrw3-v6xc

  2. Revision 1 · created ·

    Published from osv record GHSA-35g6-rrw3-v6xc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-61687

Advisory: FlowiseAI/Flosise has File Upload vulnerability
IDs: CVE-2025-61687, GHSA-35g6-rrw3-v6xc
Record: https://patchnext.com/advisories/cve-2025-61687 (revision 2, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flowise 3.0.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm flowise: affected >= 3.0.7, <= 3.0.7; fixed in 3.0.8

## Suggested inspection (read-only)
- `npm ls flowise --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flowise.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-35g6-rrw3-v6xc (OSV record GHSA-35g6-rrw3-v6xc lists affected ranges: npm flowise >=3.0.7 <3.0.8 (fixed))
- Verified: https://github.com/advisories/GHSA-35g6-rrw3-v6xc (GitHub-reviewed advisory GHSA-35g6-rrw3-v6xc lists affected ranges: npm flowise >=3.0.7 <=3.0.7)

Commands are suggestions: review each one before running it.

Loading voting…