Semantic MediaWiki vulnerable to stored XSS through wikitext via improper use of non-reserved data attributes
CVE-2025-61682GHSA-hg8h-557g-q8pp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mediawiki/semantic-media-wiki 7.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist mediawiki/semantic-media-wiki
- Affected
- >= 3.1.0, < 7.0.0
- Fixed in
- 7.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hg8h-557g-q8pp lists affected ranges: Packagist mediawiki/semantic-media-wiki >=3.1.0 <7.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hg8h-557g-q8pp lists affected ranges: Packagist mediawiki/semantic-media-wiki >=3.1.0 <7.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L
- EPSS
- CVE-2025-61682: 0.40% estimated exploitation activity in the next 30 days; percentile 34.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The SemanticMediaWiki extension inserts the unsanitized value of a data attribute into the DOM as HTML, allowing for stored XSS through wikitext. Details In ext.smw.js, the data-subtab attribute of all elements with the smw-subtab class is parsed as JSON and appended to the innerHTML of the element: https://github.com/SemanticMediaWiki/SemanticMediaWiki/blob/62f1fa765b626e21d88999b97a3e8029db9fd385/res/smw/ext.smw.js#L37-L42 However, most data attributes (except for reserved ones) like data-subtab can be used in wikitext. Therefore, it is possible to insert arbitrary HTML and JS through wikitext. The decoded (" will turn to ", but it will be decoded when it is retrieved through .dataset) value of the data-subtab attribute in the payload is "<img src='' onerror=alert(1)". This is valid JSON and returns a string with <img src='' onerror=alert(1) when being decoded. PoC 1. Create a page with the following contents: 2. Visit the page <img width="991" height="465" alt="image"…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-hg8h-557g-q8pp
- Revision 1 · created ·
Published from osv record GHSA-hg8h-557g-q8pp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-61682 Advisory: Semantic MediaWiki vulnerable to stored XSS through wikitext via improper use of non-reserved data attributes IDs: CVE-2025-61682, GHSA-hg8h-557g-q8pp Record: https://patchnext.com/advisories/cve-2025-61682 (revision 2, source checked 26 Oct 2026, 14:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mediawiki/semantic-media-wiki 7.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist mediawiki/semantic-media-wiki: affected >= 3.1.0, < 7.0.0; fixed in 7.0.0 ## Suggested inspection (read-only) - Packagist mediawiki/semantic-media-wiki: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mediawiki/semantic-media-wiki. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hg8h-557g-q8pp (OSV record GHSA-hg8h-557g-q8pp lists affected ranges: Packagist mediawiki/semantic-media-wiki >=3.1.0 <7.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-hg8h-557g-q8pp (GitHub-reviewed advisory GHSA-hg8h-557g-q8pp lists affected ranges: Packagist mediawiki/semantic-media-wiki >=3.1.0 <7.0.0) Commands are suggestions: review each one before running it.
Loading voting…