Skip to content

← Actionable
Medium, CVSS 6.1

October CMS Vulnerable to Stored XSS via Branding Styles

CVE-2025-61676GHSA-wvpq-h33f-8rp6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (october/system 4.0.12, 3.7.13), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist october/system

    Affected
    <= 3.7.12>= 4.0.0, <= 4.0.11
    Fixed in
    3.7.13, 4.0.12

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:N
EPSS
  • CVE-2025-61676: 0.27% estimated exploitation activity in the next 30 days; percentile 19.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A cross-site scripting (XSS) vulnerabilities was identified in October CMS backend configuration forms: - Branding and Appearances Styles A user with the Customize Backend Styles permission could inject malicious HTML/JS into the stylesheet input at Settings → Branding & Appearance → Styles. A specially crafted input could break out of the intended <style context, allowing arbitrary script execution across backend pages for all users. --- Impact - Persistent XSS across the backend interface. - Exploitable by lower-privileged accounts with the above permissions. - Potential consequences include privilege escalation, session hijacking, and execution of unauthorized actions in victim sessions. --- Patches The vulnerability has been patched in v4.0.12 and v3.7.13. Stylesheet inputs are now sanitized to prevent injection of arbitrary HTML/JS. All users are strongly encouraged to upgrade to the latest patched version. --- Workarounds If upgrading immediately is not possible: - Restrict the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wvpq-h33f-8rp6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-61676

Advisory: October CMS Vulnerable to Stored XSS via Branding Styles
IDs: CVE-2025-61676, GHSA-wvpq-h33f-8rp6
Record: https://patchnext.com/advisories/cve-2025-61676 (revision 1, source checked 26 Oct 2026, 14:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: october/system 4.0.12, 3.7.13. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist october/system: affected <= 3.7.12; >= 4.0.0, <= 4.0.11; fixed in 3.7.13, 4.0.12

## Suggested inspection (read-only)
- Packagist october/system: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on october/system.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wvpq-h33f-8rp6 (GitHub-reviewed advisory GHSA-wvpq-h33f-8rp6 lists affected ranges: Packagist october/system >=0 =4.0.0 <=4.0.11)

Commands are suggestions: review each one before running it.

Loading voting…