Skip to content

← Actionable
Medium, CVSS 6.0amended

Jupyter Server has an open redirection vulnerability in next query parameter

CVE-2025-61669GHSA-qh7q-6qm3-653w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyter-server 2.18.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.0 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N · score source
EPSS
  • CVE-2025-61669: 0.24% estimated exploitation activity in the next 30 days; percentile 15.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The ?next=... URL query parameter has an open redirection vulnerability. In jupyterserver<=2.17.0, this URL query parameter allows redirection to arbitrary external domains, which can be exploited to facilitate phishing attacks on server users. Details The vulnerability is caused by insufficient validation in the LoginFormHandler.redirectsafe() method. - Source code reference: https://github.com/jupyter-server/jupyterserver/blob/987ebdd5e188cdc49751b01a0d6782d686492a53/jupyterserver/auth/login.py#L33-L76 This vulnerability was originally reported by Noriaki Iwasaki. All discovery credit goes to them. PoC 1. Navigate to http://localhost:8888/login?next=///google.com 2. Observe that the user is redirected to google.com despite it being an external domain. The external domain passed in the ?next parameter may be replaced with a malicious lookalike to facilitate phishing attacks. Jupyter Server deployments served on a public domain are especially vulnerable, as prod.company.com…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-qh7q-6qm3-653w

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-qh7q-6qm3-653w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-61669

Advisory: Jupyter Server has an open redirection vulnerability in `next` query parameter
IDs: CVE-2025-61669, GHSA-qh7q-6qm3-653w
Record: https://patchnext.com/advisories/cve-2025-61669 (revision 3, source checked 26 Oct 2026, 13:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: jupyter-server 2.18.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI jupyter-server: affected <= 2.17.0; fixed in 2.18.0

## Suggested inspection (read-only)
- `python -m pip show jupyter-server`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jupyter-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qh7q-6qm3-653w (OSV record GHSA-qh7q-6qm3-653w lists affected ranges: PyPI jupyter-server >=0 <2.18.0 (fixed))
- Verified: https://github.com/advisories/GHSA-qh7q-6qm3-653w (GitHub-reviewed advisory GHSA-qh7q-6qm3-653w lists affected ranges: PyPI jupyter-server >=0 <=2.17.0)

Commands are suggestions: review each one before running it.

Loading voting…