Apache Pyfory python is vulnerable to deserialization of untrusted data
CVE-2025-61622GHSA-538v-3wq9-4h3r
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pyfory
- Affected
- >= 0.12.0, < 0.12.3
- Fixed in
- 0.12.3
PyPI pyfury
- Affected
- >= 0.1.0, <= 0.10.3
- Fixed in
- no fixed version recorded
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-538v-3wq9-4h3r lists affected ranges: PyPI pyfory >=0.12.0 =0.1.0 <=0.10.3
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-538v-3wq9-4h3r lists affected ranges: PyPI pyfory >=0.12.0 =0.1.0 <=0.10.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2025-61622: 45.13% estimated exploitation activity in the next 30 days; percentile 98.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Deserialization of untrusted data in python in pyfory versions 0.12.0 through 0.12.2, or the legacy pyfury versions from 0.1.0 through 0.10.3: allows arbitrary code execution. An application is vulnerable if it reads pyfory serialized data from untrusted sources. An attacker can craft a data stream that selects pickle-fallback serializer during deserialization, leading to the execution of pickle.loads, which is vulnerable to remote code execution. Users are recommended to upgrade to pyfory version 0.12.3 or later, which has removed pickle fallback serializer and thus fixes this issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-538v-3wq9-4h3r
- Revision 1 · created ·
Published from osv record GHSA-538v-3wq9-4h3r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-61622 Advisory: Apache Pyfory python is vulnerable to deserialization of untrusted data IDs: CVE-2025-61622, GHSA-538v-3wq9-4h3r Record: https://patchnext.com/advisories/cve-2025-61622 (revision 2, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: pyfory 0.12.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pyfory: affected >= 0.12.0, < 0.12.3; fixed in 0.12.3 - PyPI pyfury: affected >= 0.1.0, <= 0.10.3 ## Suggested inspection (read-only) - `python -m pip show pyfory`: prints the installed version. Run with the environment that serves production active. - `python -m pip show pyfury`: prints the installed version. Run with the environment that serves production active. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pyfory, pyfury. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-538v-3wq9-4h3r (OSV record GHSA-538v-3wq9-4h3r lists affected ranges: PyPI pyfory >=0.12.0 =0.1.0 <=0.10.3) - Verified: https://github.com/advisories/GHSA-538v-3wq9-4h3r (GitHub-reviewed advisory GHSA-538v-3wq9-4h3r lists affected ranges: PyPI pyfory >=0.12.0 =0.1.0 <=0.10.3) Commands are suggestions: review each one before running it.
Loading voting…