Skip to content

← Actionable
High, CVSS 7.7amended

OpenNext for Cloudflare (opennextjs-cloudflare) has a SSRF vulnerability via /_next/image endpoint

CVE-2025-6087GHSA-c7mq-gh6q-6q7c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@opennextjs/cloudflare 1.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:H/SI:N/SA:N · score source
EPSS
  • CVE-2025-6087: 0.97% estimated exploitation activity in the next 30 days; percentile 61.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
  • CVE-2026-3125: 0.40% estimated exploitation activity in the next 30 days; percentile 34.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A Server-Side Request Forgery (SSRF) vulnerability was identified in the @opennextjs/cloudflare package. The vulnerability stems from an unimplemented feature in the Cloudflare adapter for Open Next, which allowed unauthenticated users to proxy arbitrary remote content via the `/_next/image` endpoint. This issue allowed attackers to load remote resources from arbitrary hosts under the victim site’s domain for any site deployed using the Cloudflare adapter for Open Next. For example: `https://victim-site.com/_next/image?url=https://attacker.com`. In this example, attacker-controlled content from attacker.com is served through the victim site’s domain (`victim-site.com`), violating the same-origin policy and potentially misleading users or other services.

Impact - SSRF via unrestricted remote URL loading - Arbitrary remote content loading - Potential internal service exposure or phishing risks through domain abuse

Mitigation The following mitigations have been put in place:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  2. Revision 2 · amended ·

    Amended from osv record GHSA-rvpw-p7vw-wj3m

  3. Revision 1 · created ·

    Published from osv record GHSA-c7mq-gh6q-6q7c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-6087

Advisory: OpenNext for Cloudflare (opennextjs-cloudflare) has a SSRF vulnerability via /_next/image endpoint
IDs: CVE-2025-6087, GHSA-c7mq-gh6q-6q7c
Record: https://patchnext.com/advisories/cve-2025-6087 (revision 3, source checked 24 Oct 2026, 22:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @opennextjs/cloudflare 1.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @opennextjs/cloudflare: affected < 1.3.0; fixed in 1.3.0

## Suggested inspection (read-only)
- `npm ls @opennextjs/cloudflare --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @opennextjs/cloudflare.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-c7mq-gh6q-6q7c (OSV record GHSA-c7mq-gh6q-6q7c lists affected ranges: npm @opennextjs/cloudflare >=0 <1.17.1 (fixed))
- Verified: https://osv.dev/vulnerability/GHSA-rvpw-p7vw-wj3m (OSV record GHSA-rvpw-p7vw-wj3m lists affected ranges: npm @opennextjs/cloudflare >=0 <1.3.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…