Free5GC is vulnerable to DoS via the Nudm_SubscriberDataManagement API
CVE-2025-60633GHSA-3j9f-7w24-pcqg
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/free5gc/openapi
- Affected
- < 1.2.2
- Fixed in
- 1.2.2
Go github.com/free5gc/udm
- Affected
- <= 1.4.0
- Fixed in
- no fixed version recorded
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3j9f-7w24-pcqg lists affected ranges: Go github.com/free5gc/udm >=0 =0 <1.2.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2025-60633: 0.38% estimated exploitation activity in the next 30 days; percentile 32.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in Free5GC v4.0.0 and v4.0.1 allowing an attacker to cause a denial of service via the NudmSubscriberDataManagement API.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3j9f-7w24-pcqg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-60633 Advisory: Free5GC is vulnerable to DoS via the Nudm_SubscriberDataManagement API IDs: CVE-2025-60633, GHSA-3j9f-7w24-pcqg Record: https://patchnext.com/advisories/cve-2025-60633 (revision 1, source checked 26 Oct 2026, 15:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: github.com/free5gc/openapi 1.2.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/free5gc/openapi: affected < 1.2.2; fixed in 1.2.2 - Go github.com/free5gc/udm: affected <= 1.4.0 ## Suggested inspection (read-only) - Go github.com/free5gc/openapi: check the installed version with your package manager. - Go github.com/free5gc/udm: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/free5gc/openapi, github.com/free5gc/udm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3j9f-7w24-pcqg (GitHub-reviewed advisory GHSA-3j9f-7w24-pcqg lists affected ranges: Go github.com/free5gc/udm >=0 =0 <1.2.2) Commands are suggestions: review each one before running it.
Loading voting…