Skip to content

← Actionable
High, CVSS 8.3

Podman Improper Certificate Validation; machine missing TLS verification

CVE-2025-6032GHSA-65gg-3w2w-hr4h

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/containers/podman/v5

    Affected
    < 5.5.2
    Fixed in
    5.5.2
  • Go github.com/containers/podman/v4

    Affected
    >= 4.8.0, <= 4.9.5
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.3 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H
EPSS
  • CVE-2025-6032: 0.52% estimated exploitation activity in the next 30 days; percentile 43.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The podman machine init command fails to verify the TLS certificate when downloading the VM images from an OCI registry (which it does by default since 5.0.0) allowing a possible Man In The Middle attack. Patches https://github.com/containers/podman/commit/726b506acc8a00d99f1a3a1357ecf619a1f798c3 Fixed in v5.5.2 Workarounds Download the disk image manually via some other tool that verifies the TLS connection. Then pass the local image as file path (podman machine init --image ./somepath)

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-65gg-3w2w-hr4h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-6032

Advisory: Podman Improper Certificate Validation; machine missing TLS verification
IDs: CVE-2025-6032, GHSA-65gg-3w2w-hr4h
Record: https://patchnext.com/advisories/cve-2025-6032 (revision 1, source checked 26 Oct 2026, 15:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: github.com/containers/podman/v5 5.5.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/containers/podman/v5: affected < 5.5.2; fixed in 5.5.2
- Go github.com/containers/podman/v4: affected >= 4.8.0, <= 4.9.5

## Suggested inspection (read-only)
- Go github.com/containers/podman/v5: check the installed version with your package manager.
- Go github.com/containers/podman/v4: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/containers/podman/v5, github.com/containers/podman/v4.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-65gg-3w2w-hr4h (GitHub-reviewed advisory GHSA-65gg-3w2w-hr4h lists affected ranges: Go github.com/containers/podman/v5 >=0 =4.8.0 <=4.9.5)

Commands are suggestions: review each one before running it.

Loading voting…