Skip to content

← Actionable
High, CVSS 8.1

phpMyFAQ duplicate email registration allows multiple accounts with the same email

CVE-2025-59943GHSA-9wj2-4hcm-r74j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (thorsten/phpmyfaq 4.0.13), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
EPSS
  • CVE-2025-59943: 0.42% estimated exploitation activity in the next 30 days; percentile 35.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary phpMyFAQ does not enforce uniqueness of email addresses during user registration. This allows multiple distinct accounts to be created with the same email. Because email is often used as an identifier for password resets, notifications, and administrative actions, this flaw can cause account ambiguity and, in certain configurations, may lead to privilege escalation or account takeover. Details An account management logic flaw in phpMyFAQ allows attackers to register multiple accounts under the same email address. If email is used for password reset or administrative flows, this may result in account takeover, loss of accountability, and abuse of business logic. PoC 1.Register a user with email test@example.com 2.Register another user with the same email. 3.Both accounts appear in /admin/?action=user&useraction=listallusers. <img width="1150" height="628" alt="image" src="https://github.com/user-attachments/assets/8c19f01a-e897-4ca7-b3f8-fcf83e6ff952" / Impact -Data integrity…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9wj2-4hcm-r74j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-59943

Advisory: phpMyFAQ duplicate email registration allows multiple accounts with the same email
IDs: CVE-2025-59943, GHSA-9wj2-4hcm-r74j
Record: https://patchnext.com/advisories/cve-2025-59943 (revision 1, source checked 26 Oct 2026, 14:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: thorsten/phpmyfaq 4.0.13. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist thorsten/phpmyfaq: affected >= 4.0.7, < 4.0.13; fixed in 4.0.13

## Suggested inspection (read-only)
- Packagist thorsten/phpmyfaq: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on thorsten/phpmyfaq.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9wj2-4hcm-r74j (GitHub-reviewed advisory GHSA-9wj2-4hcm-r74j lists affected ranges: Packagist thorsten/phpmyfaq >=4.0.7 <4.0.13)

Commands are suggestions: review each one before running it.

Loading voting…