mkdocs-include-markdown-plugin susceptible to unvalidated input colliding with substitution placeholders
CVE-2025-59940GHSA-v39m-5m9j-m9w9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mkdocs-include-markdown-plugin 7.1.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI mkdocs-include-markdown-plugin
- Affected
- < 7.1.8
- Fixed in
- 7.1.8
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v39m-5m9j-m9w9 lists affected ranges: PyPI mkdocs-include-markdown-plugin >=0 <7.1.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v39m-5m9j-m9w9 lists affected ranges: PyPI mkdocs-include-markdown-plugin >=0 <7.1.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
- EPSS
- CVE-2025-59940: 0.34% estimated exploitation activity in the next 30 days; percentile 27.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact CWE-20: Improper Input Validation Low impact Patches Patched in v7.1.8 (commit https://github.com/mondeja/mkdocs-include-markdown-plugin/commit/7466d67aa0de8ffbc427204ad2475fed07678915) Workarounds No
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-v39m-5m9j-m9w9
- Revision 1 · created ·
Published from osv record GHSA-v39m-5m9j-m9w9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-59940 Advisory: mkdocs-include-markdown-plugin susceptible to unvalidated input colliding with substitution placeholders IDs: CVE-2025-59940, GHSA-v39m-5m9j-m9w9 Record: https://patchnext.com/advisories/cve-2025-59940 (revision 2, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mkdocs-include-markdown-plugin 7.1.8. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI mkdocs-include-markdown-plugin: affected < 7.1.8; fixed in 7.1.8 ## Suggested inspection (read-only) - `python -m pip show mkdocs-include-markdown-plugin`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mkdocs-include-markdown-plugin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-v39m-5m9j-m9w9 (OSV record GHSA-v39m-5m9j-m9w9 lists affected ranges: PyPI mkdocs-include-markdown-plugin >=0 <7.1.8 (fixed)) - Verified: https://github.com/advisories/GHSA-v39m-5m9j-m9w9 (GitHub-reviewed advisory GHSA-v39m-5m9j-m9w9 lists affected ranges: PyPI mkdocs-include-markdown-plugin >=0 <7.1.8) Commands are suggestions: review each one before running it.
Loading voting…