Skip to content

← Actionable
Critical, CVSS 9.4amended

get-jwks: poisoned JWKS cache allows post-fetch issuer validation bypass

CVE-2025-59936GHSA-qc2q-qhf3-235m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (get-jwks 11.0.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm get-jwks

    Affected
    <= 11.0.1
    Fixed in
    11.0.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.4 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L
EPSS
  • CVE-2025-59936: 0.40% estimated exploitation activity in the next 30 days; percentile 34.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A vulnerability in get-jwks can lead to cache poisoning in the JWKS key-fetching mechanism. Details When the iss (issuer) claim is validated only after keys are retrieved from the cache, it is possible for cached keys from an unexpected issuer to be reused, resulting in a bypass of issuer validation. This design flaw enables a potential attack where a malicious actor crafts a pair of JWTs, the first one ensuring that a chosen public key is fetched and stored in the shared JWKS cache, and the second one leveraging that cached key to pass signature validation for a targeted iss value. The vulnerability will work only if the iss validation is done after the use of get-jwks for keys retrieval, which usually is the common case. PoC Server code: Exploit server that generates the JWT pair and send the public RSA key to the victim server: The first JWT token will create a cache entry with the chosen public key and have the following format:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-qc2q-qhf3-235m

  2. Revision 1 · created ·

    Published from osv record GHSA-qc2q-qhf3-235m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-59936

Advisory: get-jwks: poisoned JWKS cache allows post-fetch issuer validation bypass
IDs: CVE-2025-59936, GHSA-qc2q-qhf3-235m
Record: https://patchnext.com/advisories/cve-2025-59936 (revision 2, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: get-jwks 11.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm get-jwks: affected <= 11.0.1; fixed in 11.0.2

## Suggested inspection (read-only)
- `npm ls get-jwks --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on get-jwks.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qc2q-qhf3-235m (OSV record GHSA-qc2q-qhf3-235m lists affected ranges: npm get-jwks >=0 <11.0.2 (fixed))
- Verified: https://github.com/advisories/GHSA-qc2q-qhf3-235m (GitHub-reviewed advisory GHSA-qc2q-qhf3-235m lists affected ranges: npm get-jwks >=0 <=11.0.1)

Commands are suggestions: review each one before running it.

Loading voting…