Skip to content

← Actionable
High, CVSS 8.2amended

Apollo Embedded Sandbox and Explorer vulnerable to CSRF via window.postMessage origin-validation bypass

CVE-2025-59845GHSA-w87v-7w53-wwxv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@apollo/explorer 3.7.3; @apollo/sandbox 2.7.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:H/A:N
EPSS
  • CVE-2025-59845: 0.16% estimated exploitation activity in the next 30 days; percentile 5.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A Cross-Site Request Forgery (CSRF) vulnerability was identified in Apollo’s Embedded Sandbox and Embedded Explorer. The vulnerability arises from missing origin validation in the client-side code that handles window.postMessage events. A malicious website can send forged messages to the embedding page, causing the victim’s browser to execute arbitrary GraphQL queries or mutations against their GraphQL server while authenticated with the victim’s cookies. Who is impacted Anyone embedding Apollo Sandbox or Apollo Explorer in their website may have been affected by this vulnerability. - Users who embed Apollo Sandbox or Apollo Explorer in their websites via npm packages (@apollo/sandbox and @apollo/explorer) or direct links to Apollo’s CDN. - Users running Apollo Router with embedded Sandbox enabled. This served the vulnerable code from Apollo’s CDN. - Users running Apollo Server with embedded Sandbox or Explorer enabled. Embedded Sandbox is enabled by default when NODEENV is…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-w87v-7w53-wwxv

  2. Revision 1 · created ·

    Published from osv record GHSA-w87v-7w53-wwxv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-59845

Advisory: Apollo Embedded Sandbox and Explorer vulnerable to CSRF via window.postMessage origin-validation bypass
IDs: CVE-2025-59845, GHSA-w87v-7w53-wwxv
Record: https://patchnext.com/advisories/cve-2025-59845 (revision 2, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @apollo/explorer 3.7.3; @apollo/sandbox 2.7.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @apollo/explorer: affected < 3.7.3; fixed in 3.7.3
- npm @apollo/sandbox: affected < 2.7.2; fixed in 2.7.2

## Suggested inspection (read-only)
- `npm ls @apollo/explorer --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @apollo/sandbox --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @apollo/explorer, @apollo/sandbox.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-w87v-7w53-wwxv (OSV record GHSA-w87v-7w53-wwxv lists affected ranges: npm @apollo/sandbox >=0 =0 <3.7.3 (fixed))
- Verified: https://github.com/advisories/GHSA-w87v-7w53-wwxv (GitHub-reviewed advisory GHSA-w87v-7w53-wwxv lists affected ranges: npm @apollo/sandbox >=0 =0 <3.7.3)

Commands are suggestions: review each one before running it.

Loading voting…