Skip to content

← Actionable
Low, CVSS 2.1amended

JupyterLab LaTeX typesetter links did not enforce noopener attribute

CVE-2025-59842GHSA-vvfj-2jqx-52jm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyterlab 4.4.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.1 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-59842: 0.24% estimated exploitation activity in the next 30 days; percentile 15.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Links generated with LaTeX typesetters in Markdown files and Markdown cells in JupyterLab and Jupyter Notebook did not include the noopener attribute. This is deemed to have no impact on the default installations. Theoretically users of third-party LaTeX-rendering extensions could find themselves vulnerable to reverse tabnabbing attacks if: - links generated by those extensions included target=blank (no such extensions are known at time of writing) and - they were to click on a link generated in LaTeX (typically visibly different from other links). For consistency with handling on other links, new versions of JupyterLab will enforce noopener and target=blank on all links generated by typesetters. The former will harden the resilience of JupyterLab to extensions with lack of secure defaults in link rendering, and the latter will improve user experience by preventing accidental state loss when clicking on links rendered by LaTeX typesetters. Impact Since the official LaTeX typesetter…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-vvfj-2jqx-52jm

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-vvfj-2jqx-52jm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-59842

Advisory: JupyterLab LaTeX typesetter links did not enforce `noopener` attribute
IDs: CVE-2025-59842, GHSA-vvfj-2jqx-52jm
Record: https://patchnext.com/advisories/cve-2025-59842 (revision 3, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: jupyterlab 4.4.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI jupyterlab: affected <= 4.4.7; fixed in 4.4.8

## Suggested inspection (read-only)
- `python -m pip show jupyterlab`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jupyterlab.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vvfj-2jqx-52jm (OSV record GHSA-vvfj-2jqx-52jm lists affected ranges: PyPI jupyterlab >=0 <4.4.8 (fixed))
- Verified: https://github.com/advisories/GHSA-vvfj-2jqx-52jm (GitHub-reviewed advisory GHSA-vvfj-2jqx-52jm lists affected ranges: PyPI jupyterlab >=0 <=4.4.7)

Commands are suggestions: review each one before running it.

Loading voting…