Gardener provider extensions vulnerable to code injection when Terraform is used for infrastructure provisioning
CVE-2025-59823GHSA-227x-7mh8-3cf6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/gardener/gardener-extension-provider-azure 1.55.0; github.com/gardener/gardener-extension-provider-aws 1.64.0; github.com/gardener/gardener-extension-provider-openstack 1.49.0; github.com/gardener/gardener-extension-provider-gcp 1.46.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/gardener/gardener-extension-provider-azure
- Affected
- < 1.55.0
- Fixed in
- 1.55.0
Go github.com/gardener/gardener-extension-provider-aws
- Affected
- < 1.64.0
- Fixed in
- 1.64.0
Go github.com/gardener/gardener-extension-provider-openstack
- Affected
- < 1.49.0
- Fixed in
- 1.49.0
Go github.com/gardener/gardener-extension-provider-gcp
- Affected
- < 1.46.0
- Fixed in
- 1.46.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-227x-7mh8-3cf6 lists affected ranges: Go github.com/gardener/gardener-extension-provider-aws >=0 =0 =0 =0 <1.49.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2025-59823: 0.49% estimated exploitation activity in the next 30 days; percentile 42.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A security vulnerability was discovered in Gardener when Terraformer is used for infrastructure provisioning. This vulnerability could allow a user with administrative privileges for a Gardener project to obtain control over the seed cluster where the shoot cluster is managed. This CVE affects all Gardener installations where Terraformer is used/can be enabled for infrastructure provisioning with any of the affected components mentioned below. Affected Components • gardener-extension-provider-gcp • gardener-extension-provider-azure • gardener-extension-provider-openstack • gardener-extension-provider-aws Affected Versions • gardener-extension-provider-gcp < v1.46.0 • gardener-extension-provider-azure < v1.55.0 • gardener-extension-provider-openstack < v1.49.0 • gardener-extension-provider-aws < v1.64.0 Fixed versions • gardener-extension-provider-gcp = v1.46.0 • gardener-extension-provider-azure = v1.55.0 • gardener-extension-provider-openstack = v1.49.0 •…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-227x-7mh8-3cf6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-59823 Advisory: Gardener provider extensions vulnerable to code injection when Terraform is used for infrastructure provisioning IDs: CVE-2025-59823, GHSA-227x-7mh8-3cf6 Record: https://patchnext.com/advisories/cve-2025-59823 (revision 1, source checked 26 Oct 2026, 15:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/gardener/gardener-extension-provider-azure 1.55.0; github.com/gardener/gardener-extension-provider-aws 1.64.0; github.com/gardener/gardener-extension-provider-openstack 1.49.0; github.com/gardener/gardener-extension-provider-gcp 1.46.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/gardener/gardener-extension-provider-azure: affected < 1.55.0; fixed in 1.55.0 - Go github.com/gardener/gardener-extension-provider-aws: affected < 1.64.0; fixed in 1.64.0 - Go github.com/gardener/gardener-extension-provider-openstack: affected < 1.49.0; fixed in 1.49.0 - Go github.com/gardener/gardener-extension-provider-gcp: affected < 1.46.0; fixed in 1.46.0 ## Suggested inspection (read-only) - Go github.com/gardener/gardener-extension-provider-azure: check the installed version with your package manager. - Go github.com/gardener/gardener-extension-provider-aws: check the installed version with your package manager. - Go github.com/gardener/gardener-extension-provider-openstack: check the installed version with your package manager. - Go github.com/gardener/gardener-extension-provider-gcp: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/gardener/gardener-extension-provider-azure, github.com/gardener/gardener-extension-provider-aws, github.com/gardener/gardener-extension-provider-openstack, github.com/gardener/gardener-extension-provider-gcp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-227x-7mh8-3cf6 (GitHub-reviewed advisory GHSA-227x-7mh8-3cf6 lists affected ranges: Go github.com/gardener/gardener-extension-provider-aws >=0 =0 =0 =0 <1.49.0) Commands are suggestions: review each one before running it.
Loading voting…