Skip to content

← Actionable
Medium, CVSS 6.3

Http4s vulnerable to HTTP Request Smuggling due to improper handling of HTTP trailer section

CVE-2025-59822GHSA-wcwh-7gfw-5wrr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.http4s:http4s-ember-core_2.12 0.23.31; org.http4s:http4s-ember-core_3 1.0.0-M45, 0.23.31; org.http4s:http4s-ember-core_2.13 1.0.0-M45, 0.23.31), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-59822: 0.37% estimated exploitation activity in the next 30 days; percentile 31.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary http4s is vulnerable to HTTP Request Smuggling due to improper handling of HTTP trailer section. This vulnerability could enable attackers to: - Bypass front-end servers security controls - Launch targeted attacks against active users - Poison web caches Pre-requisites for the exploitation: the web appication has to be deployed behind a reverse-proxy that forwards trailer headers. Details The HTTP chunked message parser, after parsing the last body chunk, calls parseTrailers (ember-core/shared/src/main/scala/org/http4s/ember/core/ChunkedEncoding.scala#L122-142). This method parses the trailer section using Parser.parse, where the issue originates. parse has a bug that allows to terminate the parsing before finding the double CRLF condition: when it finds an header line that does not include the colon character, it continues parsing with state=false looking for the header name till reaching the condition else if (current == lf && (idx 0 && message(idx - 1) == cr)) that sets…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wcwh-7gfw-5wrr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-59822

Advisory: Http4s vulnerable to HTTP Request Smuggling due to improper handling of HTTP trailer section
IDs: CVE-2025-59822, GHSA-wcwh-7gfw-5wrr
Record: https://patchnext.com/advisories/cve-2025-59822 (revision 1, source checked 26 Oct 2026, 16:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.http4s:http4s-ember-core_2.12 0.23.31; org.http4s:http4s-ember-core_3 1.0.0-M45, 0.23.31; org.http4s:http4s-ember-core_2.13 1.0.0-M45, 0.23.31. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.http4s:http4s-ember-core_2.12: affected < 0.23.31; fixed in 0.23.31
- Maven org.http4s:http4s-ember-core_3: affected < 0.23.31; >= 1.0.0-M1, < 1.0.0-M45; fixed in 0.23.31, 1.0.0-M45
- Maven org.http4s:http4s-ember-core_2.13: affected < 0.23.31; >= 1.0.0-M1, < 1.0.0-M45; fixed in 0.23.31, 1.0.0-M45

## Suggested inspection (read-only)
- Maven org.http4s:http4s-ember-core_2.12: check the installed version with your package manager.
- Maven org.http4s:http4s-ember-core_3: check the installed version with your package manager.
- Maven org.http4s:http4s-ember-core_2.13: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.http4s:http4s-ember-core_2.12, org.http4s:http4s-ember-core_3, org.http4s:http4s-ember-core_2.13.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wcwh-7gfw-5wrr (GitHub-reviewed advisory GHSA-wcwh-7gfw-5wrr lists affected ranges: Maven org.http4s:http4s-ember-core_2.12 >=0 =0 =1.0.0-M1 =0 =1.0.0-M1 <1.0.0-M45)

Commands are suggestions: review each one before running it.

Loading voting…