OSV-SCALIBR's Container Image Unpacking Vulnerable to Arbitrary File Write via Path Traversal
CVE-2025-5981GHSA-2hcm-q3f4-fjgw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/google/osv-scalibr 0.2.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/google/osv-scalibr
- Affected
- >= 0.1.3, < 0.2.1
- Fixed in
- 0.2.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2hcm-q3f4-fjgw lists affected ranges: Go github.com/google/osv-scalibr >=0.1.3 <0.2.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.7 · CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:A/VC:H/VI:L/VA:N/SC:H/SI:L/SA:N · score source
- EPSS
- CVE-2025-5981: 0.22% estimated exploitation activity in the next 30 days; percentile 12.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Arbitrary file write as the OSV-SCALIBR user on the host system via a path traversal vulnerability when using OSV-SCALIBR's unpack() function for container images. Particularly, when using the CLI flag --remote-image on untrusted container images.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2hcm-q3f4-fjgw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-5981 Advisory: OSV-SCALIBR's Container Image Unpacking Vulnerable to Arbitrary File Write via Path Traversal IDs: CVE-2025-5981, GHSA-2hcm-q3f4-fjgw Record: https://patchnext.com/advisories/cve-2025-5981 (revision 1, source checked 26 Oct 2026, 15:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/google/osv-scalibr 0.2.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/google/osv-scalibr: affected >= 0.1.3, < 0.2.1; fixed in 0.2.1 ## Suggested inspection (read-only) - Go github.com/google/osv-scalibr: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/google/osv-scalibr. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2hcm-q3f4-fjgw (GitHub-reviewed advisory GHSA-2hcm-q3f4-fjgw lists affected ranges: Go github.com/google/osv-scalibr >=0.1.3 <0.2.1) Commands are suggestions: review each one before running it.
Loading voting…