Skip to content

← Actionable
Critical, CVSS 9.0

DNN Vulnerable to Stored Cross-Site Scripting (XSS) in the Prompt module

CVE-2025-59545GHSA-2qxc-mf4x-wr29

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (dotnetnuke.core 10.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.0 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
EPSS
  • CVE-2025-59545: 0.52% estimated exploitation activity in the next 30 days; percentile 43.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The Prompt module allows execution of commands that can return raw HTML. Malicious input, even if sanitized for display elsewhere, can be executed when processed through certain commands, leading to potential script execution (XSS). Description The application sanitizes most user-submitted data before displaying it in entry forms. However, the Prompt module is capable of running commands whose output is treated as HTML. This creates a vulnerability where a malicious user can craft input containing embedded scripts or harmful markup. If such malicious content is later processed by a Prompt command and returned as HTML, it bypasses the standard sanitation mechanisms. Simply executing a specific command through the Prompt module could render this untrusted data and cause unintended script execution in the browser specially in the context of a super-user.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-2qxc-mf4x-wr29

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-59545

Advisory: DNN Vulnerable to Stored Cross-Site Scripting (XSS) in the Prompt module
IDs: CVE-2025-59545, GHSA-2qxc-mf4x-wr29
Record: https://patchnext.com/advisories/cve-2025-59545 (revision 1, source checked 26 Oct 2026, 17:03 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: dotnetnuke.core 10.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet dotnetnuke.core: affected < 10.1.0; fixed in 10.1.0

## Suggested inspection (read-only)
- NuGet dotnetnuke.core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on dotnetnuke.core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2qxc-mf4x-wr29 (GitHub-reviewed advisory GHSA-2qxc-mf4x-wr29 lists affected ranges: NuGet dotnetnuke.core >=0 <10.1.0)

Commands are suggestions: review each one before running it.

Loading voting…