Claude Code can execute commands prior to the startup trust dialog
CVE-2025-59536GHSA-4fgq-fpq9-mr3g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@anthropic-ai/claude-code 1.0.111), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.0.111
- Fixed in
- 1.0.111
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4fgq-fpq9-mr3g lists affected ranges: npm @anthropic-ai/claude-code >=0 <1.0.111 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4fgq-fpq9-mr3g lists affected ranges: npm @anthropic-ai/claude-code >=0 <1.0.111
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-59536: 24.89% estimated exploitation activity in the next 30 days; percentile 97.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Due to a bug in the startup trust dialog implementation, Claude Code could be tricked to execute code contained in a project before the user accepted the startup trust dialog. Exploiting this requires a user to start Claude Code in an untrusted directory. Users on standard Claude Code auto-update will have received this fix automatically. Users performing manual updates are advised to update to the latest version. Thank you to https://hackerone.com/avivdon for reporting this issue!
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-4fgq-fpq9-mr3g
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-4fgq-fpq9-mr3g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-59536 Advisory: Claude Code can execute commands prior to the startup trust dialog IDs: CVE-2025-59536, GHSA-4fgq-fpq9-mr3g Record: https://patchnext.com/advisories/cve-2025-59536 (revision 3, source checked 26 Oct 2026, 12:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @anthropic-ai/claude-code 1.0.111. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @anthropic-ai/claude-code: affected < 1.0.111; fixed in 1.0.111 ## Suggested inspection (read-only) - `npm ls @anthropic-ai/claude-code --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @anthropic-ai/claude-code. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4fgq-fpq9-mr3g (OSV record GHSA-4fgq-fpq9-mr3g lists affected ranges: npm @anthropic-ai/claude-code >=0 <1.0.111 (fixed)) - Verified: https://github.com/advisories/GHSA-4fgq-fpq9-mr3g (GitHub-reviewed advisory GHSA-4fgq-fpq9-mr3g lists affected ranges: npm @anthropic-ai/claude-code >=0 <1.0.111) Commands are suggestions: review each one before running it.
Loading voting…