Skip to content

← Actionable
Medium, CVSS 6.5

DNN allows loading unused themes on anonymous clients through query parameters

CVE-2025-59535GHSA-wq2j-w9pm-7x2p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (dotnetnuke.core 10.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
EPSS
  • CVE-2025-59535: 0.43% estimated exploitation activity in the next 30 days; percentile 37.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Arbitrary themes can be loaded through query parameters. If an installed theme had a vulnerability, even if it was not used on any page, this could be loaded on unsuspecting clients without knowledge of the site owner. Details Many people who run DNN sites have a number of installed themes that they do not actually use. This could be because they were testing many themes during initial setup, because they have changed themes over time, or because they have development and production versions of a theme. Whatever the reason, many times the unused themes will become outdated over time as site admins wouldn't have reason to update something that is not used. However, this could introduce an entry point to exploit a vulnerable theme by making the server run the unused theme for unsuspecting client requests. Depending on the vulnerability in a theme, this could lead to server side or client side arbitrary code execution. With DNN 10.1.0 this functionality is now disabled by…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wq2j-w9pm-7x2p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-59535

Advisory: DNN allows loading unused themes on anonymous clients through query parameters
IDs: CVE-2025-59535, GHSA-wq2j-w9pm-7x2p
Record: https://patchnext.com/advisories/cve-2025-59535 (revision 1, source checked 26 Oct 2026, 17:03 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: dotnetnuke.core 10.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet dotnetnuke.core: affected < 10.1.0; fixed in 10.1.0

## Suggested inspection (read-only)
- NuGet dotnetnuke.core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on dotnetnuke.core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wq2j-w9pm-7x2p (GitHub-reviewed advisory GHSA-wq2j-w9pm-7x2p lists affected ranges: NuGet dotnetnuke.core >=0 <10.1.0)

Commands are suggestions: review each one before running it.

Loading voting…