Skip to content

← Actionable
High, CVSS 7.5amended

FlowiseAI/Flowise has Server-Side Request Forgery (SSRF) vulnerability

CVE-2025-59527GHSA-hr92-4q35-4j3m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flowise 3.0.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm flowise

    Affected
    >= 3.0.5, <= 3.0.5
    Fixed in
    3.0.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2025-59527: 5.46% estimated exploitation activity in the next 30 days; percentile 92.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary --- A Server-Side Request Forgery (SSRF) vulnerability was discovered in the /api/v1/fetch-links endpoint of the Flowise application. This vulnerability allows an attacker to use the Flowise server as a proxy to access internal network web services and explore their link structures. The impact includes the potential exposure of sensitive internal administrative endpoints. Details --- Vulnerability Overview The fetch-links feature in Flowise is designed to extract links from external websites or XML sitemaps. It performs an HTTP request from the server to the user-supplied URL and parses the response (HTML or XML) to extract and return links. The issue arises because the feature performs these HTTP requests without validating the user-supplied URL. In particular, when the relativeLinksMethod parameter is set to webCrawl or xmlScrape, the server directly calls the fetch() function with the provided URL, making it vulnerable to SSRF attacks. Root Cause The fetch() function is…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-hr92-4q35-4j3m

  2. Revision 1 · created ·

    Published from osv record GHSA-hr92-4q35-4j3m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-59527

Advisory: FlowiseAI/Flowise has Server-Side Request Forgery (SSRF) vulnerability
IDs: CVE-2025-59527, GHSA-hr92-4q35-4j3m
Record: https://patchnext.com/advisories/cve-2025-59527 (revision 2, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flowise 3.0.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm flowise: affected >= 3.0.5, <= 3.0.5; fixed in 3.0.6

## Suggested inspection (read-only)
- `npm ls flowise --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flowise.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hr92-4q35-4j3m (OSV record GHSA-hr92-4q35-4j3m lists affected ranges: npm flowise >=3.0.5 <3.0.6 (fixed))
- Verified: https://github.com/advisories/GHSA-hr92-4q35-4j3m (GitHub-reviewed advisory GHSA-hr92-4q35-4j3m lists affected ranges: npm flowise >=3.0.5 <=3.0.5)

Commands are suggestions: review each one before running it.

Loading voting…