Skip to content

← Actionable
Unrated

Memory leak that enables remote Denial of Service against applications processing TLS client certificates

CVE-2025-59464

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (node 24.13.0, 22.22.0, 20.20.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • runtime node

    Affected
    >= 20.0.0, < 20.20.0>= 22.0.0, < 22.22.0>= 24.0.0, < 24.13.0
    Fixed in
    24.13.0, 20.20.0, 22.22.0

Sources

  • nodejs.org runtime security intelligence

    The nodejs.org release index dates the first patched release for CVE-2025-59464 to 2026-01-12.

    VerifiedObserved Official nodejs.org release index (dist/index.json).

  • raw.githubusercontent.com runtime security intelligence

    Node.js security working group core entry 159 lists CVE-2025-59464 affecting node >=20.0.0 =22.0.0 =24.0.0 <24.13.0

    VerifiedObserved Structured Node.js security-wg core vulnerability record maintained by the Node.js project.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2025-59464: 0.27% estimated exploitation activity in the next 30 days; percentile 19.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A memory leak in Node.js’s OpenSSL integration occurs when converting `X.509` certificate fields to UTF-8 without freeing the allocated buffer. When applications call `socket.getPeerCertificate(true)`, each certificate field leaks memory, allowing remote clients to trigger steady memory growth through repeated TLS connections. Over time this can lead to resource exhaustion and denial of service.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · published ·

    Published from vendor_advisory record nodejs-security-wg:core:159

  2. Revision 1 · created ·

    Created from vendor_advisory record nodejs-security-wg:core:159

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-59464

Advisory: Memory leak that enables remote Denial of Service against applications processing TLS client certificates
IDs: CVE-2025-59464
Record: https://patchnext.com/advisories/cve-2025-59464 (revision 2, source checked 26 Oct 2026, 16:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: node 24.13.0, 22.22.0, 20.20.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- runtime node: affected >= 20.0.0, < 20.20.0; >= 22.0.0, < 22.22.0; >= 24.0.0, < 24.13.0; fixed in 24.13.0, 20.20.0, 22.22.0

## Suggested inspection (read-only)
- runtime node: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on node.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://nodejs.org/dist/index.json (The nodejs.org release index dates the first patched release for CVE-2025-59464 to 2026-01-12.)
- Verified: https://raw.githubusercontent.com/nodejs/security-wg/main/vuln/core/159.json (Node.js security working group core entry 159 lists CVE-2025-59464 affecting node >=20.0.0 =22.0.0 =24.0.0 <24.13.0)

Commands are suggestions: review each one before running it.

Loading voting…