@conventional-changelog/git-client has Argument Injection vulnerability
CVE-2025-59433GHSA-vh25-5764-9wcr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@conventional-changelog/git-client 2.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @conventional-changelog/git-client
- Affected
- < 2.0.0
- Fixed in
- 2.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vh25-5764-9wcr lists affected ranges: npm @conventional-changelog/git-client >=0 <2.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vh25-5764-9wcr lists affected ranges: npm @conventional-changelog/git-client >=0 <2.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:H
- EPSS
- CVE-2025-59433: 0.22% estimated exploitation activity in the next 30 days; percentile 12.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Background on exploitation This vulnerability manifests with the library's getTags() API, which allows specifying extra parameters passed to the git log command. In another API by this library - getRawCommits() there are secure practices taken to ensure that the extra parameter path is unable to inject an argument by ending the git log command with the special shell syntax --. However, the library does not follow the same practice for getTags() not attempts to sanitize for user input, validate the given params, or restrcit them to an allow list. Nor does it properly pass command-line flags to the git binary using the double-dash POSIX characters (--) to communicate the end of options. Thus, allowing users to exploit an argument injection vulnerability in Git due to the --output= command-line option that results with overwriting arbitrary files. Exploit 1. Install @conventional-changelog/git-client@1.0.1 or earlier 2. Prepare a Git directory to be used as source 3. Create the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-vh25-5764-9wcr
- Revision 1 · created ·
Published from osv record GHSA-vh25-5764-9wcr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-59433 Advisory: @conventional-changelog/git-client has Argument Injection vulnerability IDs: CVE-2025-59433, GHSA-vh25-5764-9wcr Record: https://patchnext.com/advisories/cve-2025-59433 (revision 2, source checked 26 Oct 2026, 12:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @conventional-changelog/git-client 2.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @conventional-changelog/git-client: affected < 2.0.0; fixed in 2.0.0 ## Suggested inspection (read-only) - `npm ls @conventional-changelog/git-client --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @conventional-changelog/git-client. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vh25-5764-9wcr (OSV record GHSA-vh25-5764-9wcr lists affected ranges: npm @conventional-changelog/git-client >=0 <2.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-vh25-5764-9wcr (GitHub-reviewed advisory GHSA-vh25-5764-9wcr lists affected ranges: npm @conventional-changelog/git-client >=0 <2.0.0) Commands are suggestions: review each one before running it.
Loading voting…