Skip to content

← Actionable
Medium, CVSS 4.3amended

lobe-chat has an Open Redirect

CVE-2025-59426GHSA-xph5-278p-26qx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@lobehub/chat 1.130.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
EPSS
  • CVE-2025-59426: 0.35% estimated exploitation activity in the next 30 days; percentile 28.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description --- Vulnerability Overview The project's OIDC redirect handling logic constructs the host and protocol of the final redirect URL based on the X-Forwarded-Host or Host headers and the X-Forwarded-Proto value. In deployments where a reverse proxy forwards client-supplied X-Forwarded- headers to the origin as-is, or where the origin trusts them without validation, an attacker can inject an arbitrary host and trigger an open redirect that sends users to a malicious domain. Vulnerable Code Analysis https://github.com/lobehub/lobe-chat/blob/aa841a3879c30142720485182ad62aa0dbd74edc/src/app/(backend)/oidc/consent/route.ts#L113-L127 PoC --- curl Example <img width="1504" height="304" alt="image" src="https://github.com/user-attachments/assets/b71d937d-7be2-49db-8f3d-e07371912800" / Impact --- - It can force users to redirect to untrusted external domains, leading to subsequent attacks such as phishing, credential harvesting, and session fixation. - It can disrupt the OAuth/OIDC…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-xph5-278p-26qx

  2. Revision 1 · created ·

    Published from osv record GHSA-xph5-278p-26qx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-59426

Advisory: lobe-chat has an Open Redirect
IDs: CVE-2025-59426, GHSA-xph5-278p-26qx
Record: https://patchnext.com/advisories/cve-2025-59426 (revision 2, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @lobehub/chat 1.130.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @lobehub/chat: affected < 1.130.1; fixed in 1.130.1

## Suggested inspection (read-only)
- `npm ls @lobehub/chat --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @lobehub/chat.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xph5-278p-26qx (OSV record GHSA-xph5-278p-26qx lists affected ranges: npm @lobehub/chat >=0 <1.130.1 (fixed))
- Verified: https://github.com/advisories/GHSA-xph5-278p-26qx (GitHub-reviewed advisory GHSA-xph5-278p-26qx lists affected ranges: npm @lobehub/chat >=0 <1.130.1)

Commands are suggestions: review each one before running it.

Loading voting…